Author Topic: SP2 Exported Textures Washed Out  (Read 7869 times)

So I thought it was something I was doing wrong and I watched all the videos over and over to check the settings. I spent past two days trying to fix this or find solutions. Only this latest link I found inspired me to try it with SP1 and it worked which isolated the issue to SP2.

With Substance Painter 2.0 to UE4 4.10 Is broken and I can't seem to fix it.

If I import my model make a standard texture then export it using the UE4 Material pack and bring it into UE4 the base color texture is washed out like its been bleached with light. ( Nothing fancy or special just place a texture on it and export it )

If I do the same workflow process with Substance painter 1 the issue is not there.

I recently just paid money to get the 2.0 upgraded version. I check the software for an update and nothing.

When will there be a patch to resolve this SP 2.0 export issue to UE4

Hey osias.lee,

I'm not aware of any issues with Substance Painter 2 during export. Can you specify your issue a bit further and provide screenshots?
I would like to try to recreate that behaviour on my machine.

Best Regards
Environment Artist - Twitter

Hi Guys,

I had the same issue this evening when exporting with the UE4 packed textures in a 4.10 project, but I found the cause and I found a work around.
I just did some tests, and I identified the 16bit png export format as the issue (default export format).

I first noticed the issue when exporting with UE4 packed textures with 16bit max .png.  Prior to UE4 integration, the resulting output appeared ok when viewed in photoshop or any image viewer. However, when importing in UE4, any srgb flagged textures appear as to be in linear color space in the preview window, but are flagged as srgb in the attributes. Curiously, when you unchecked the srgb flag, it reverts to expected output from Painter. Perhaps the flag setting inversely sets the expected desired color space.

So I re-exported some the same textures (PBR metal/Rough and then UE4 packed again) and on my first try with 8 bit jpgs, the srgb textures imported in unreal appear ok and work as intended. I also tried .targa 8bit and it works correctly too.

Thus avoid using 16bit png at the moment. I haven't gone back to SP1 to try 16bit pngs, though I did try again a using new photoshop file (avoiding painter altogether) and saved as a 16bit .png and I get the same washed out issue in Unreal. Thus, this also could clearly be an Unreal bug as well. Note, I have not tried this using UE 4.11 yet to see if this is resolved.

***EDIT - Update: I also tried with UE4 4.11 and it fails with the 16bit pngs.

Hope this helped,

Last Edit: April 15, 2016, 12:46:54 pm
Bruno Parillo
Technical Artist

Hes got the ticket when I un-check SRGB in unreal the texture looks the way i expect it to be in the texture viewer but whenever I add that texture to a material its still washed out.

But from what it sounds like is its a 16 bit png importer issue in unreal then. Also that doesn't matter if you update to the latest version of unreal which just came out bug still exists.

Well I guess I will go post on UE4 forums then
Last Edit: April 16, 2016, 11:04:29 pm

UE4 doesn't support 16 bit sRGB textures. You can either export a 8 bit sRGB texture or a 16 bit linear texture (if that actually is a thing). Or just export a 16 bit sRGB texture and fix it in the material:

I reported the issue to Epic Games regarding 16bit sRGB textures.
Don't forget your log file. It can be exported from the Help menu of the software.
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.