Author Topic: Exported textures never have an alpha channel  (Read 3205 times)

I'm trying to export my specular map with the glossiness map in the alpha channel for use in Killing Floor 2. However the exported map never has an alpha channel. I tried png and tga.

This is how my export panel looks:



I'd really appreciate it if someone could help me out with this.

What does your texture set settings look like ?
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Like this:


Does anyone have an idea? It's a somewhat "pressing" issue, I'd love to know what I'm doing wrong.  :-\

Well first, I see that in your export preset you are using the wrong "normal" input. Use the normal from the converted map list instead, this one combine the additional map and the height channel.

Do you have any errors/warnings in the log after exporting ? When you drag and dropped the Glossiness channel in the Alpha slot of your export preset, which option did you choose ?

I did a quick test on my side and was able to export fine.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Well first, I see that in your export preset you are using the wrong "normal" input. Use the normal from the converted map list instead, this one combine the additional map and the height channel.

Ah thank you. Do I just drag it into the RGB slot? Do I use opengl or directx?

Do you have any errors/warnings in the log after exporting ? When you drag and dropped the Glossiness channel in the Alpha slot of your export preset, which option did you choose ?

No errors or warnings. This is what it says: "[MapExporterDialog] Starting map export
[MapExporter] Export duration: 0s
[MapExporterDialog] Map export ended"

I chose the "From grayscale" option, but I also tried the "Alpha channel" option, both didn't work.

The use OpenGL/DirectX map depends of your target engine. Choose the one that you need.

For your export issue, I'm afraid that without seeing the project I won't be able to suggest something new. Do you think you could share it with me (via PM if you want) ?
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Sent you a PM, thanks for looking into it.

I just gave a try to your project and even reproduced your export preset. I don't have any issues on my side, the channels export fine.

Can you attach here the export map that you get ?
Also can you check that you are using the right export preset ? What happens if you sue the preset "PBR SpecGloss" ?
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Sure, I sent you a PM again. :) It doesn't seem to work any way I try it.

Very odd, I also tried tga but I still get an alpha channel that is not empty as his yours.
What happens if you try png of psd instead ? Do you get transparency on the Specular texture in your export preset ?

Can you also attach your log file file after an export ?
See : https://support.allegorithmic.com/documentation/display/SPDOC/Exporting+the+log+file
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.