Author Topic: Problems rendering Substance with Vray on Mac  (Read 5813 times)

Hello,
We are testing substance with V-ray on our PC, and not having any problems. However, when we try to render view or batch render the same scene on a Mac, maya crashes. 
Any ideas?

Hi,

I'll do my best to get this solved, but I'll start with a list of questions : )

What version of Maya and Vray are you using? Are you using custom substances or a stock substance purchased from allegorithmic? Is the scene something you can upload for me to take a look?

Cheers,

Wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja

Hi Wes,
We are using Maya 2013, and Vray 2.0.
We're using the Bitmap2Material plugin.
The scene is just a simple subdivided plane, with a substance node using one of the included sample textures converted to a material with B2M.

Thanks.

Hi,

Thanks for the info. I'll take a look and see if I can produce the crash. A couple more questions : ) 

What version of B2M are you using?
Are you using any specific Vray materials?

I'll be in touch.

Wes
Last Edit: November 13, 2013, 10:19:16 pm
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja

It's Bitmap2Material version 2.1.
It's just the regular vray mtl.
Last Edit: November 13, 2013, 10:31:18 pm

It's Bitmap2Material version 2.1.
It's just the regular vray mtl.

Hi,

I tested Vray and didn't experience any crashes on OSX. However, my configuration is a different than what you are using.

I tested Maya 2014 with Vray mtl and was using substance_bitmap2material_2_1_2_build_12446. You mentioned that you were using B2M 2.1. Have you tried B2M 2.1.2 build 12446? I don't think that the Maya version difference would be the issue as they both use the same Substance Engine. It could be an issue with B2M 2.1 vs 2.1.2.

Cheers,

Wes


Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja

I believe I have the most recent version it B2M. How can I verify that it's the bitmap2material_2_1_2_build_12446?
I've attached our test file. The substance node would need to be converted to a vray mtl, and then rendered in vray. Neither of which we've been able to successfully do on a mac. If you are able to, it may be an issue of Maya 2014 vs Maya 2013.

We actually solved the problem. Updating V-Ray has fixed the issue on the macs and it now renders fine. Odd that it works on the PC with the old vray version, but anyway. Thanks for the help.
Last Edit: November 26, 2013, 10:30:51 pm

We actually solved the problem. Updating V-Ray has fixed the issue on the macs and it now renders fine. Odd that it works on the PC with the old vray version, but anyway. Thanks for the help.

Great news it's fixed. Thanks for reporting.

Cheers,
Wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja