Author Topic: Substance Painter no longer responding  (Read 970 times)


I very recently (few days ago) bought Substance Painter Subscription here, and it appeared to work fine until I updated it to the newest version.

Now all that happens (even with older versions) is the program popping its start up window, but as soon as it actually starts, all that remains is a white window, saying the program is not responding.

I already went over everything that could cause it in the ''standard issue'' pages ( and, tried older versions, as well as changing the TDR value, changing the name of the default shelf within the program files (Substance Painter -> Resources -> Shelf -> Allegorithmic), and doing re-installations, but nothing has proven to work, so far.

I haven't been able to actually take the software in use now, so it isn't very likely that there are any preferences interfering.

Its about a MSI Desktop with a GeForce GTX 1070 Ti inside, is there anyone who can help?

Last Edit: September 24, 2019, 10:24:47 am

Please include your log file:

If you cannot get it from the application go here:

Retrieving the log file manually on the disk
If you are unable to launch Substance Painter, you can retrieve the log file manually by going into the following folder :

Windows: C:\Users\*username*\AppData\Local\Allegorithmic\Substance Painter\log.txt
Mac OS: Macintosh > Users > *username* > Library > Application Support > Allegorithmic > Substance Painter > log.txt
Linux: /home/*username*/.local/share/Allegorithmic/Substance\ Painter/log.txt
On  Mac OS  "library" is a hidden folder.
On  Windows  "Appdata" is a hidden folder.
On Linux ".local" is a hidden folder.

Here's the log

It's still the same with the 2.2 version. I have included the new log here.

Can someone please help? I am on a Pro license, and haven't even been able to use it...

We have already gone trough about everything that could cause this (as I mentioned above).

The computer appears to also have an Intel I7, but when I go to the Device manager (-> Display Adapters) to disable it, it only shows the Geforce GTX 1070 Ti. I was advised to not turn the Geforce off.

So, is there anything else that we can try? Or prehaps disable the I7 somewhere else?
Last Edit: September 24, 2019, 11:02:43 am

Are you running two Geforces? I was suggesting to disable one if you're using SLI.

No... Only a Geforce GTX and apperently an Intel i7, as I said, but I don't see where to disable the i7, if that's even possible

No... Only a Geforce GTX and apperently an Intel i7, as I said, but I don't see where to disable the i7, if that's even possible

Well your I7 is your CPU, you need to disable your on-board GPU.

Under 'Device Manager'

Right click - Disable.

If you don't see it listed you should update your drivers for it.

I just wasn't sure if Painter maybe was using your on-board card instead of your GeForce.

Also, did you try making a new Windows User and trying that? Beyond this you might have to do a fresh install then as something is causing a conflict.
Last Edit: September 24, 2019, 08:55:40 pm

I just updated the Intel until it was fully up to date again, but it is still not showing in the Device manager -> Display Adapters  :-\.

However, I created a new user on the PC and reinstalled Substance Painter from there.
It appears to work now, but only on the new user account. The original account (admin) is still showing a not-responding white screen.

I rather work only from the original account, so is there a way to make it work there as well?

Please try to follow the guides provided on those pages, there is likely a mis-configuration somewhere that prevent Substance Painter to start properly :
Don't forget your log file. It can be exported from the Help menu of the software.
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.