Warning: filesize(): stat failed for /var/www/html/cache/data_b3d9e87568fea535c0e7d85b33710dd7-SMF-modSettings.php in /var/www/html/Sources/Load.php on line 2808
Locating Cooker Warning?

Author Topic: Locating Cooker Warning?  (Read 1952 times)

I'm getting the following cooker warnings, but I'm not sure how to locate the problem:




My primary graph ("Grime") is a little complex, which is the reason I'm having trouble locating the issue. I've tried using the search bar, but all nodes become faded out with both of these variable identifiers typed into the text box. Do these warnings mean the variables are being requested somewhere, but don't exist? Can anyone help me figure out how to narrow down the locations of these issues, or just to understand what the issues are?

I know they are just warnings, but would still rather clean them up if possible.
Thanks for any help!

Can you send me the .sbs ?
Product Manager - Allegorithmic

I can, but it has a ton of custom dependencies. It's a graph I've been working on for months, so it has become a bit cumbersome. I'm not sure it would do any good to send it by itself? Let me know if you still want to look at it.

If anyone can just help me understand what that error means (ERROR_UNKNOWN_INSTANCE_PARAMETER_NAME), I can probably figure out the problem. Google didn't turn up much. I wasn't sure if it meant I had an exposed variable with no usage, or a usage with no variable, or something else entirely. The names of these two variables definitely sound familiar, so I'm sure it is something I changed and didn't complete properly.

If I expose the variable of a sub-graph, and then expose/attach that to a parent graph variable, then later delete the sub-graph variable entirely, will this cause any issues for the parent graph? I'm pretty sure I did this a few times. When I went to clean up the parent graph, it appeared to already be correct. But I wondered if it created some type of ghost bug.

Usually you get an error when:
- you create a graph
- create a parameter on this graph
- instantiate this graph into second graph
- change the parameter value
- go back to the graph
- delete the parameter

-> if you try to publish the second graph, you'll get a warning about the deleted parameter.

Only way to fix this at the moment:
- create the missing parameter again
- on the node instance: reset the parameter value to default
- now delete the parameter
Product Manager - Allegorithmic

Okay, yes, I've noticed this behavior a couple times. Something similar (strange) happens when you change the type of a variable in the sub-graph (such as from float3 to float2) when it doesn't match the default value. Its like the extra component value garbles up the variable value read.

Does it resolve the issue you're referring to by completely deleting the instance of the first graph in the second, then re-adding it? Since it has been so long since I deleted the exposed variable, I would have a hard time remembering anything about it. If not, what about copying & pasting the parent graph? Does the issue get copied with it?
Last Edit: May 23, 2019, 08:12:07 pm

Yes, deleting the instance and creating it again solves the issue.
Product Manager - Allegorithmic

this was a godsend, had huge slowdown from this error and now everything is nice and speedy :)
deleting the instanced graph and dragging it in fresh and reconnecting the parameters solved it.