Author Topic: Strange Normals Shading on Imported Meshes  (Read 7372 times)

Hi folks,

From time to time when I import a mesh into Substance Painter, the polygons are shaded strangely (some light, some dark) as though the normals were inverted or the smoothing groups messed up, but double-checking the model shows no issues.  I have tried making sure everything on the model is properly welded, that all the normals are facing the same direction, that the smoothing groups are correct, and have tried exporting/importing in various different formats like OBJ (my default), FBX, etc, all to no avail.

3DS Max shades the meshes correctly, as does Daz Studio (the ultimate destination), but Substance Painter will give me this strange lighting/shading effect.  It is entirely visual within Substance Painter -- the exported textures look fine in either Max or Daz.  But having all this weird shading sometimes gives me trouble when painting textures just from the standpoint of being able to judge what it really looks like when applying a texture across two surfaces that are shaded light, dark, or in between.

It's not happening with everything I import into Substance Painter, only certain objects.  This one I am working on today is 90% simple boxes, and the remaining parts are extruded splines.  I just don't get it.  Has this happened to anyone else?  Is there a known way to fix this?  Any help would be appreciated.


Added screenshots of the Max and DS viewports, as well as a shot of the UVW unwrap showing that nothing is out of bounds or overlapping strangely
Last Edit: January 17, 2019, 06:38:11 pm

Please attach a log file :

It's hard to say what could be wrong, but this is likely related to incorrect data in the mesh file that the importer has to cleanup. The cleanup process may not generate what you are expecting.
Don't forget your log file. It can be exported from the Help menu of the software.
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Here is the log file.

Can you attach a simple test mesh that has the same issue ?
Don't forget your log file. It can be exported from the Help menu of the software.
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

It doesn't happen with every mesh.  Only once a month or so.  I work on hundreds of meshes a month.  I can't remember the last time I had the issue before this one.  It is simply a pain in my ass that I am trying to solve now and potentially in the future so I can continue working.  Sorry.  I really cannot reproduce it.  If I could, I would be able to solve it myself.

Adding the following:

I exploded the mesh elements into individual objects and exported the entire selection to one OBJ (as opposed to having all the elements attached into a single object).  The exploded mesh imports into Substance Painter normally.  So that is a solution for this instance, but a bad one.  Would still like to know what is causing the issue in the first place, as basically every mesh I work on is comprised of multiple attached elements and this problem is not terribly common.

Thanks for your help so far!

Without a mesh file to investigate it's gonna be complicated for us to replicate the problem.
Don't forget your log file. It can be exported from the Help menu of the software.
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

But do you understand that if I was able to make it happen... ie, reproduce the steps myself... this would not be a problem for me, and I could just submit a bug report with the steps and keep going with my work?  The intent of my original question was primarily to see if this was already a known issue with a known fix or workaround or a known cause.

For what it's worth, it seems to involve errors with the mesh related either to previously flipped normals or unwelded verts, possibly artifacts in the OBJ.

One thing I noticed, that may be of help in reproducing:  this mesh was one of the occasional meshes I get that crash 3DS Max when trying to attach another elements.  Select one element, click the attach button, click on another separate element, Max crashes (sometimes attempting to save a copy).  The fix for that is to convert the original element to Editable Mesh, attach the new element, then convert back to Editable Poly.  After doing that, Max no longer crashes when attempting to attach a new element to that object.  Once I converted to object to Editable Mesh and back to Editable Poly, it also stopped doing the weird shading thing in Painter.

As I said in an earlier reply in this thread, the model was 90% simple boxes.  No real way any of that could have gotten fouled up.  However, the trim pieces were extruded splines, one of which initially extruded with flipped normals (which I flipped back), and which were bridged together.  There could have been unwelded vertices in one of these areas the first time the mesh was exported, but I don't think there were.  When I checked later, element-by-element, I found nothing unwelded.  But I'm almost certain the root of the problem was an error in the original OBJ export.  That first export imported into Painter with the weird shading/lighting issues, and also imported back into a different Max scene with several faces triangulated and the vertices broken so that one previously welded object had become two or more broken elements.  That's when I first checked the model in the source scene for broken welds without finding any, and unified the normals even though they looked correct, and basically went over all of my other troubleshooting steps.  Eventually I got the OBJ to import back into Max without being triangulated and broken, but it wasn't until I did the convert-to-mesh and then convert-to-poly that it started working properly in Painter.

Anyway, I got this particular model to work properly after some messing around.  If I have time later I will attempt to reproduce the problem, or at least attempt to locate a model in my library that has the same issue in Painter and see if my steps to fix it work on that one as well, then report back here.  If you're inclined to see if you can reproduce it yourself, I plan to start by exporting a mesh with broken welds and another with a single flipped normal, to see if that causes it.  But I suspect the cause is somewhat more complicated than that and, as I said, related to whatever bug causes Max to crash when attempting to attach objects in Editable Poly.  Also, for what it's worth, I am working with Max 2016 and the next to most recent version of Painter (I have an update available but haven't installed it yet).

Thanks again for the help.


in my project shadows and strange behavior of the mesh occurs with extruded elements. If I draw a new cube, it's ok. I`m works in Blender.

You need to provide a copy of your high and low if you want help. A majority of these issues are user error, with a small fraction being a limitation or a bug based on what I've seen on these forums.
I teach people how to use Substance Painter. :)

The shadows itself, and colored differently, it's just a matter of environment light display. If you test it changing the display settings, it will change the colors and lights on the mesh. But when it comes to weird shading and appearing odd shapes on the mesh, then it's a different matter that I don't know why. You gotta test it, sometimes, the internet doesn't provide the answer we need.

I think this is the same issue I just solved for myself after several hours of tinkering with my model. I was having issues where some faces looked like they had inverted normals even though they looked completely fine in Blender. In my case, it turned out to be an issue with the modifiers being applied to the model. I have a bevel and a mirror modifier on every object, and it looks like having mirror on top of the stack causes these problems sometimes. Moving it down so that it computes after my bevel modifier fixes it for me. Hope this helps you, I know I was pulling hair trying to find an answer online.

1st time: I just had this issue too. As best as I can explain it, (not the one below), but the offending trapezoidal shape with a flair at the bottom or the irregularity was spread over 2 rectangular polys. I checked for all the possible goofs like inverted normals but found nothing. So I replaced the two rectangular polys and exported again and that fixed the issue. The only odd thing about those two rectangular polys was when I deleted them a couple of extra edges remained that the fix routines didn't catch. I made sure to remove them too before exporting.

2nd time: And then it happened again with another object but this time I got a picture and the fix. If I did this right you'll see in the picture the red highlight shows the shadowy thingamajig in the 3D display linked to the 2D display. And what that is the way I drew the seams part of the desk front collapsed onto itself. I checked the original UV for the object and that was correct. After re-seaming the area the latest iteration doesn't do that.

With the first time I didn't look at the UV to see if the same kind of collision happened. I doubt it since all I did was to replace the offending polys. With the second time I did have to fix the UV but I didn't have to replace any polys.

Last Edit: January 27, 2021, 05:26:13 pm