Author Topic: Substance running on wrong GPU! How can I change that?  (Read 2318 times)

When I try to start it says "Substance Painter currently run on a integrated graphics adapter, but it seems that an integrated graphics card is also available. Using the dedicated GPU is recommended for a better experience. Try to re-launch the application again and force it's execution on it."

When managing the NVIDIA 3D-Settings I don't find the option to change the GPU (I created an own profile for Substance). Neither is there a setting to change it in Substance itself.

I followed exactly as shown here (https://support.allegorithmic.com/documentation/display/SPDOC/Running+on+integrated+GPU) but there simply isn't a "preferred graphics processor" setting for me like shown in other screenshots on the internet.

Edit: Looks like the "preferred graphics processor" setting is only available on laptops...

GPUs:
GTX 960
Intel(R) HD Graphics 4600 GPU


Any ideas?
Last Edit: June 04, 2018, 09:14:17 pm

Sometimes, the option can be found in the settings app of your Intel Integrated card rather than in the NVidia driver app.

Sometimes, the option can be found in the settings app of your Intel Integrated card rather than in the NVidia driver app.

I forgot to mention I tried that too. Can't find a setting for that anywhere. What setting are you referring to?

SOLVED:
This is very strange but somehow the problem was the main monitor I changed a week ago. I selected the other one as main-monitor in the windows settings and now the message doesn't show up anymore.