Author Topic: File Opens and Textures Show on Object, but Layers are Empty and Uneditable  (Read 1507 times)

I am a student and I have been working on a project that's due in a couple of days. Substance crashed during a save and now something really weird is happening. The file opens up and all of my textures are displayed on my model just like before, but I can't edit anything. All of the thumbnails on the layers are empty, and if I hide the layers, nothing happens. It acts like it's letting me paint and edit the layers, but nothing changes in the viewport. I can even create new layers, but I can't paint on them at all. I've tried exporting the files, and it acts like it's exporting, it even creates a new folder and a .lock file, but then nothing ever happens. I don't understand why I can open the file and see all the textures, but none of them seem to actually exist.
Please let me know if this can be fixed or any files recovered at all.
(will try to attach file in later post, the internet is not wanting to upload it right now)

Could you try opening your project on a more recent version of Substance Painter (in trial mode for example) ?
If you are a student you can get a free license as well.

We don't provide support for Substance Painter 1.x anymore.
Don't forget your log file. It can be exported from the Help menu of the software.
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Yes, I did that earlier on one of the other computers in the lab with the more updated version and it updated the project and opened it, but still did everything the same as before. It would export the mesh, but only with the old materials applied to it, and it would act like it was going to export the textures, but nothing would ever happen.
Here is a log file from that:

Update(?) The maps in the first material layer actually have their thumbnail images, though for all the rest, it is just gray. If I bake normals again, that will change on my model in the viewport, even though then all of the maps just have gray thumbnails. This is the only thing that I have been able to get to register in the viewport other than soloing materials and post process effects. Still no errors showing in the log, at least. I'm hoping the textures files can be saved since they are still displayed in the viewport?

Update #2. It has happened two more times. Once on the same computer with the same version, and now on a different computer with the 2017 version. My project is due in a matter of hours and Substance Painter keeps apparently corrupting my files and deleting my textures. Please let me know if these are going to be salvageable or not, and what I need to do to keep this from happening anymore. Thanks.

Is there any way you could upload your probject somewhere and send us a link via private message for us to look at?

I have the same problem, can I do something?