Author Topic: UE4.3 and the Substance Plugin  (Read 11752 times)

Does it supports mobile devices?

Not yet.

what does it support? only win64 build? I tried build win32 but it was fail
Last Edit: July 21, 2014, 11:52:29 pm

hi guys,

i followed all steps, unfortunately in my case i get a:

MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: ERROR: Couldn't find referenced module 'SubstanceCore'.

any ideas? thanks.

Can you verify that you built the project in "Development" mode? Also check if your username in Windows has any special characters.

I have never managed to get the plugin included in a project. Ever. I have stopped trying.

I'm real sorry to hear that Mithril :(

If you want you can email me at and I can help you get set up.

Hello Josh, and thank you for your offer :)
But in this case far more people than me are affected, all of whom could benefit the same solution.

It's like this (step by step :) )

1. Install the official UE4 editor (for example via the launcher)
2. Download the substance plugin, and add it (as per instructions) (It works!)
3. Create a small project in UE4 (I use Blueprints), and add a few models using Substance
4. Build the following: A development build, and a shipping build.

The following will happen (always):

The development build (x64) will not add Substance plugin, on top of this it is a development build. It will not be a 'release' version. It is also the only current version using x64. But no matter, the launch will complain about the missing plugin and continue with the launch.

The shipping build is only x86 (yet) and will not include substance even if it could. Because the plugin only exist as a x64 version. Don't get me wrong, I am happy x86 is going away, but it is still here.

So there it is, it is impossible to add the plugin and still have it follow the build. It is referenced, but not added. This is something you guys do need to talk with Epic about. Because added plugins should follow, just like all the other plugins do. I have read the create c++ code part in the forum (and no that didn't work for me either) but frankly, I don't have the time to tinker around like this. I have limited time to spare, and if it doesn't work. I'll simply have to settle using it for creating textures only. And that (to be perfectly honest) is a bit annoying. That and I am confused as to why you don't have a x86 version when you obviously know the shipping build is in x86?? Update: Hmm, I saw in the main thread you do plan to add x86 support. Well, that means you only have the build issue left then :)

But again, I do appreciate the offer :) And I hope you don't get hurt feelings because that is most certainly not my intention. I do like your products.. a lot :) But I hope this will get solved in a more workable manner, in the not too distant future.

Best regards/

Last Edit: July 25, 2014, 10:58:28 am

Hi Mithril,

First off we're not hurt at all, in fact I'm grateful you post on the forums so we are aware of issues! The issue about shipping builds is known and we'll be including a 32 bit build library so it will compile.

You mentioned you tried my C++ workaround. Does DebugGame fail to compile as well in this mode?

Good news :D I downloaded the new source from Github you guys put up, and that successfully could build a release that had Substance tag along as well, of course *you* new about that ;) but still, happy days.

Best regards/

Fortunately for you I needed to do that to submit a pull request for Epic :)

Based on your issue resolution I think it would be best for us to keep our source fork on github then. Thanks for posting back your findings and I'm glad it has a good outcome :)