Author Topic: Unable to Open My Substance in Substance Designer  (Read 4366 times)

My issue is essentially this:,12650.msg55140.html#msg55140

I was working in SD6 today and my computer informed me that my space on the C drive was low. I responded by closing down a few virtual memory heavy programs including SD. SD didn't inform me of any crash or other abnormal behavior at close, but now I can't open the Substance at all.  :-\

I get an error that reads:
       XML read error:
       Premature end of document.
       Failed to create package

If the fix is to send in my .sbs may I email it privately instead of posting it here?


Hi Redhonour,

You can send me your sbs by mail or private message, I will take a look to your file !

Thanks !
QA Analyst

Stupid question but how exactly do I do that? I don't see any options for attaching files in a PM or direct email.


I've already remade the substance since this is time sensitive work, but I'd still like to relcaim access to my original substance for parity's sake.


I answered to your PM.
QA Analyst

I am having the same problem. My computer auto-restarted (I know, noob move) while I was waiting for the graph to go to 4k and I cannot open my file anymore.

Same thing. Can't open my old files.

@james.mitchell.watson.jr : if the computer rebooted while it was writing the file, it is unlikely it can be recoverered as it was probably only partially written. However, if it was not the first time you saved it, you may find an older backup version in the hidden .autosave directory next to it.

@aaaleks : Do all your older files give you the exact same error message as the original poster ("XML read error : premature end of document") ? Or is it a different message, or just only one file ?

I think, i have fixed it. Try to switch an engine to SSE2.

I wasn't able to get my latest file back, but I was able to get one from a couple hours earlier. Thank you very much for your suggestions!

I am having this same problem. I just spent 2 hours working on this substance and honestly it wasn't even too complex but I have to submit this in a few hours... Now I'm completely *****  >:(.

I'm using Substance Designer 2018 and it crashes all the time. Apparently now also destroys my work "literally". I never had this happen in SD5 which I used before. I am a bit clueless as to why it generates so many problems - I really can't open the file anymore. All the autosaves are 0kbs and there's just simply no way of recovering anything out of them - out of the 8 savefiles there's only one that isn't 0kb, and it's the second one so the progress on it is ridiculously irrelevant as more than 80% of the work is gone regardless.

I wouldn't mind redoing it but this is the second time this happens to me TONIGHT. I am wondering whether it's even worth trying again as if the file gets corrupted once again I'm gonna lose it...

I have the same problem. even though I kept saving my file. but when my file crashed., I can't open my work file. it showed xml read error.
file attached

I can't open my Substance, I have an error message "failed to read version of URL ......"  :'(

I can't open my Substance, I have an error message "failed to read version of URL ......"  :'(
Hey, please create another thread, as it may be a different issue (don't forget to join the log file).