Author Topic: [SOLVED] SD6 library thumbnail is empty  (Read 3051 times)

SD6 library thumbnail is empty   every preset i select show nothing itried to turn on all and turn off all filter and nothin work
I try to reinstall so many teram via steam    even delete all the file the resetting before install in sd6 in my document folder wont help
Last Edit: March 16, 2017, 02:44:49 pm

Hey, in the Windows menu, try "New Library View"

still empty like before

it's absolutely normal when i use steam install on my new computer at my workplace

ping @Damien Climent
Do you have an idea?


This is probably an issue with the database.
In Designer, go to 'Edit'->'Preferences'->'Library', here click on 'Rebuild Database'

If it doesn't work return in 'Edit'->'Preferences' and this time, go to 'Projects' part.
Follow the first path : 'configuration file'.
It should look like : C:/Users/USER/AppData/Local/Allegorithmic/Substance Designer/6/
In this folder, you will find 'databases' folder. Close Designer and delete the 'database' folder.

Now launch Designer and test it ! :)
QA Analyst


Thank for support

Pls continues making the greatest software ever

Nice ! :D

And you're welcome !
QA Analyst


I just installed Designer 6 and I'm having the same issues with an empty library, but I tried the fixes in this thread and they haven't solved it. Rebuilt database, deleted database, uninstalled and reinstalled application, but most of my library remains empty.

I tried opening a couple substances and it couldn't find multiple dependencies (included stuff like linear gradients, etc.), so where is this stuff exactly?

I had this same issue on my purchased copy from Steam, even restarting and making a new substance it wouldn't display anything in the Library same as in the screenshot. However, doing Windows->New Library View and closing the old Library tab fixed the issue.

Please create a specific thread, as this one is flagged as solved (each case can be unique)