Author Topic: Substance Painter 2.3.0 : AMD GPUs fix (beta build)  (Read 10516 times)

[EDIT] The fix to these issues has been integrated into Substance Painter 2.3.1.


Hello,

We are currently working on various fixes for the instabilities related to AMD GPUs (freezes, crashes, artifacts, and so on).
Let us now if the build below works better for you or if you still encounter some problems.

Download Windows : Removed
Download Linux : Removed


In case a problem still appear please :
- Attach a log file to your post (See : https://support.allegorithmic.com/documentation/display/SPDOC/Exporting+the+log+file )
- Post steps that will allow us to reproduce the issue
- Attach any other necessary ressource that would help (such as a mesh or a screenshot)

Important : this is a beta build. This version of Substance Painter is for testing purpose only, not for asset production. We don't advise and/or recommend working with this build. It is better to go back on an older version if necessary. See : https://forum.allegorithmic.com/index.php?topic=10291.0
Last Edit: October 09, 2016, 08:40:34 pm
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

This beta build works fine for me, I've tried several tools and works well.
Before the program freeze my computer.
I have a Amd Hd 7850
Thanks.

The beta build works for me. I can load the older 2.2 project, bake textures and export textures without any problems.
New projects work as well.
I have a AMD HD 7700.
Thanks
Last Edit: September 30, 2016, 08:11:42 pm
AMD FX4340 Quad-Core 4.2GHz, 16 GB RAM, GeForce GTX 1050.

It's up and running just fine. Thanks for the update.

Works just fine for me now. DxDiag is attatched and thanks for the fast fix. I hope the official patch comes soon.

I am just started an evaluation so this is tricky for me to know what the problem is.

The hotfix helped but didn't solve my problem. I can recreate the crash at will using the fire hydrant sample.

This is my second time writing this because the last time the crash locked my whole system, which is a first actually, usually it just produces the AMD driver error.

Anyway. pre-hotfix it would crash by deactivating the rust layer. Now I can cause an immediate crash just by left clicking on the rust layer itself in the layers window. That's it, crash.

I am going to install an older version and see how that goes.

I have attached my dxdiag.


edit - The Fire hydrant sample isn't in the older version but I haven't been able to cause a crash with the preview sphere. It seems to be fixed. It's also much more responsive in general. I can do a lot of things that would cause a lockup on 2.3 with no issues at all on 2.1
Last Edit: October 01, 2016, 05:43:44 am

I am just started an evaluation so this is tricky for me to know what the problem is.

The hotfix helped but didn't solve my problem. I can recreate the crash at will using the fire hydrant sample.

This is my second time writing this because the last time the crash locked my whole system, which is a first actually, usually it just produces the AMD driver error.

Anyway. pre-hotfix it would crash by deactivating the rust layer. Now I can cause an immediate crash just by left clicking on the rust layer itself in the layers window. That's it, crash.

I am going to install an older version and see how that goes.

I have attached my dxdiag.


edit - The Fire hydrant sample isn't in the older version but I haven't been able to cause a crash with the preview sphere. It seems to be fixed. It's also much more responsive in general. I can do a lot of things that would cause a lockup on 2.3 with no issues at all on 2.1
Thanks for the DxDiag.
Can you open the FireHydrant project and then export the log file to attahc it here ? (From the Help Menu)
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Thanks for the DxDiag.
Can you open the FireHydrant project and then export the log file to attahc it here ? (From the Help Menu)

Here you are. I hope it helps!

Beta build works on my computer. The normal one was freezing my machine right after creating project.

Thanks for the DxDiag.
Can you open the FireHydrant project and then export the log file to attahc it here ? (From the Help Menu)

Here you are. I hope it helps!
Your GPU drivers are not up to date. Start by updating them to see how it goes.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Thanks for the DxDiag.
Can you open the FireHydrant project and then export the log file to attahc it here ? (From the Help Menu)

Here you are. I hope it helps!
Your GPU drivers are not up to date. Start by updating them to see how it goes.

Just updated them. Using 16.9.2 now. Still crashing.

I can load new meshes now in with hotfix.  However, in no version of Substance Painter 2 can I change the shader to Alpha Blending.  The program freezes everytime I change it to Alpha Blending.  I can change the shader to Alpha Blending in Substance Painter 1.7.3.  I have an AMD R9 370 GPU.


Last Edit: October 04, 2016, 10:16:38 am

Just updated them. Using 16.9.2 now. Still crashing.
We reproduced some new strange behaviors (but no crash yet), we will look into it.

I can load new meshes now in with hotfix.  However, in no version of Substance Painter 2 can I change the shader to Alpha Blending.  The program freezes everytime I change it to Alpha Blending.  I can change the shader to Alpha Blending in Substance Painter 1.7.3.  I have an AMD R9 370 GPU.
That's really odd that it isn't working since the 2.0 version. We didn't change a thing regarding the way manage the alpha blending since it was introduced back then in 1.x. It's only with this shader ? Does it work with the Alpha Test ?
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

I can load new meshes now in with hotfix.  However, in no version of Substance Painter 2 can I change the shader to Alpha Blending.  The program freezes everytime I change it to Alpha Blending.  I can change the shader to Alpha Blending in Substance Painter 1.7.3.  I have an AMD R9 370 GPU.
That's really odd that it isn't working since the 2.0 version. We didn't change a thing regarding the way manage the alpha blending since it was introduced back then in 1.x. It's only with this shader ? Does it work with the Alpha Test ?
The alpha-test shader worked.  I updated to the optional 6.19.2 driver and now changing to Alpha Blend works. I think I may have uninstalled VulkanRT awhile ago because it looked like it had nothing to do with the AMD GPU. Thanks for your help everything is working great.
Last Edit: October 05, 2016, 09:32:08 pm

I can run Substance Painter 2.3 but can't new and open samples.
I use AMD GPU.
I can open FireHydrant.spp.
I can't open PreviewSphere.spp and new , this will be unlimited read.