Author Topic: Substance Designer 5.5 crashing on open  (Read 6316 times)

Just downloaded the latest version of Substance Designer (for OSX). Install went fine and said all was well, but Substance Designer is now crashing mid opening. Previous version was running fine.



Same thing happens to me.. just downloaded 5.5.0 to see whats new...

Just downloaded the latest version of Substance Designer (for OSX). Install went fine and said all was well, but Substance Designer is now crashing mid opening. Previous version was running fine.



Hello all,

Same problem, Substance Designer crashed after 3 secondes (on Linux install):

/u/soft/allegorithmic/Substance_Designer_5.5/ line 8:  3716 Aborted                 ${SUBSTANCE_INSTALLDIR}/Substance\ Designer
--- SIGCHLD {si_signo=SIGCHLD, si_code=CLD_KILLED, si_pid=3716, si_status=SIGABRT, si_utime=481, si_stime=56} ---
+++ exited with 134 +++

For licenses should we activate it separately when launching on new machines? or could we put license key on install folder (network install)?

Thank you,


I have El capitan 10.11.6 hackintosh and it's working. Quite slow due to the GPU support gone for IRay and cpu is using 1400% all the time with IRay render but it works. No crash whatsoever in the whole MDL tutorial.

I am not a developer and I don't really understand 99% of the output of this command but sometimes it can point to somewhere so I can google it or ask anyone how knows this things to help me.

If it crashes, chances are that dtrace shows something interesting in the last lines of the output so there we go.

cd /Applications/Substance\
sudo dtruss "./Substance\ Designer"

Astrophotography, Landscapes and 3D Computer Graphics.

@mglsys : would it be possible to create a separate thread for that so that we don't create confusion by mixing Linux issues with OSX issues (which may have different causes and would probably require different solutions) ? Please add informations such as which distribution you are using, which graphics drivers, what GPU model.

@kenp and @DMCDesign : we would also need more info: your OSX version, which Mac model you are running on, what GPU model you are using. Also, would it be possible to give us Designer's log (you can send it by PM, or email me using the "envelope" icon in the left column). The log should be located here :
/Users/<your user name>/Library/Application Support/Allegorithmic/Substance Designer/5/log.txt 

Last Edit: August 26, 2016, 04:02:48 pm

Cyrille, I've got a MacPro tower (mid 2010) dual 2.4 GHz QuadCore Intel Xeon with 32 gb ram. Running OSX El Capitan 10.11.6. I dont see log.txt in the folder /Users/<your user name>/Library/Application Support/Allegorithmic/Substance Designer/5/log.txt  there was a folder for "Substance Painter" I did a search for "Allegorithmic" and there's a folder with a similar structure (but no log file) in /Users/<your user name>/Documents/Allegorithmic/Substance Designer/5/ but its empty
Last Edit: August 26, 2016, 10:12:32 pm

@kenp : thanks for your email report. Would it be possible to also tell us which model of GPU you are using in this machine ? Also, was Designer 5.4 working fine on this machine, or is SD 5.5 the first version you have installed on this machine ?
Last Edit: August 30, 2016, 07:02:08 pm

I've got a NVIDIA Quadro K5000 4096 MB. This is the first time I've installed Substance Designer. Substance Painter (Demo) was working fine previously (now demo has expired)

Having the same issue here, only I'm running on Windows. Any time I click in the application after getting beyond the splash window, it freezes and has to be terminated.

Same issue here. I was on 5.4 and my (Live) license had run out. I tried installing my current license, and after that SD just hangs after trying to create a new substance, or trying to open an old one. I installed the latest version ( and the same thing happens.

So now I've updated my Nvidia drivers to the latest (372.70), uninstalled all versions of Substance Designer, restarted my machine, re-installed the latest version of Substance Designer ( Tried to run it, and the same thing happens as before. I can run the app and create a new substance, but the second I try to create a new graph the program freezes up and I have to kill it. I also tried switching from DirectX to SSE2, and the same thing happens.

OS Name   Microsoft Windows 10 Pro 64 bit
Version   10.0.10586 Build 10586
Processor   Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz, 4001 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date   American Megatrends Inc. 1701, 3/25/2016
SMBIOS Version   3.0
Embedded Controller Version   255.255
BIOS Mode   Legacy
BaseBoard Manufacturer   ASUSTeK COMPUTER INC.

GPU: Nvidia Geforce GTX 980
DirectX runtime version:  12.0
Driver version: 372.70

~Mike D.
Last Edit: September 08, 2016, 04:28:22 am

Similar experience here. I can open v5.5 and create a new Substance, or even open one that I made with the previous version. But when I switch to Iray rendering, it shows the sample cube but no textures.

However, as soon as I load a complex .sbs from Substance Share it says 'computing...' at the bottom and freezes the app. I've downgraded to the previous version.

I'm running a mid-2010 Mac Pro, 12-core, 24GB RAM with GTX 908Ti, all Nvidia drivers up to date.
Last Edit: September 08, 2016, 11:35:11 am