Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - gpmail1

Pages: [1] 2
1
Can you tell us how to do that?  I'm not a coding noob, but I sure am to substance.mod files.

2
All I can get it the Offset Color in my renders.  There are no generated images that I can see in any of the nodes.  My .sbar is out of Substance Designer.  Could that be it?  I'll have to find out how to make an .sbar out of Painter.

3
Was there ever an actual solution to this?  All the forums here are dead ends.  When can we actually expect Painter to run good?  I don't have a beast of a computer but all my other apps run well.

4
I never have these problems with Adobe apps., so there is hope that their code will get optimized now.

5
Over 2 years later, and this problem still exists.  I've done everything you all mention here, and nothing seems to help.  They load in slow, which I can live with.  Yet sometimes, many of them don't even load at all.

6
The new release is out and it is faster, but still way too sporadic.  Sometimes stuff draws in, sometimes it doesn't.  Brushes didn't load, then did, then didn't. No almost nothing shows up whereas last time I loaded Sub Painter all but the bottom 3 categories loaded.

7
It seems that you have more than 3000 materials in your shelf and that's what is causing the slow population of the shelf. We are looking into improving the shelf loading times but in the meantime, try triming down the amount of materials you have in your shelf or separate them between multiple shelf and load only the shelf you need for your current project.

My textures folder has 5 items and none of the thumbnails load.  I hoped the last 2 patches might change this, but nope.  I've found forums posts from 2 years ago with this issue.  When can we expect to see thumbnails again?

8
Today Painter worked much better.  It did repeat the going unresponsive when clicking a texture set, but this was after I had worked on a few of them for 30-45 minutes.  So, I'm able to get some work done, rather than have almost every selection of a texture set cause the unresponsiveness.  The file I'm working on it is not in my OneDrive folder, but in my standard Windows 10 Documents folder.

9
Okay let's keep your issue in one thread please. This will be easier to track for everybody and make sure we can follow up properly on your problems without asking you twice the same things.  :)

I hope that you all will start showing some sign of fixing these issues, and stop replying to such posts as this with "have you tried....?"  We've all tried multiple things, probably anything you can toss at us and then some. 
We need more details to figure out why you are crashing. Context is important and answering our questions will give us a better understanding of the matter. You can't expect us to "fix the problem" if we know nothing about it and can't reproduce it to investigate it. So even if you feel like our questions are rudimentary or useless, they at least provide us context.

Now here is a bit of information about the save system : we reworked the save process a few month ago so that it crash when the save doesn't finish properly instead of closing the project like before (which coud lead to data corruption). This way we can be more aware of issues and fix them properly.
Likely in your situation, there is something specific that makes you crash all the time. If we figure what it is, we can implement a fix quickly and even send you an early build since you are under a specific time constraint.

---

So I have looked latest crash report you sent us and the log mention the following :
Quote
[INFO] <Qt> "[DBG INFO][Project]" "Saving project to 'D:/OneDrive/Blizzard Student Contest/Sub Painter Exports/Hoverbike v2.spp' in mode incremental"
[WARN] <Qt> "[DBG WARNING][Data url converter]" Resource QUrl("resource://allegorithmic.1c865f2e-31a9-4e34-b620-bf248e897bfe/shape/shape?version=1915c4df5847e865e7e329d02d1c2534c7b3b703.sbsar")  can't be found, trying to find a similar one
[WARN] <Qt> "[DBG WARNING][Data url converter]" Resource QUrl("resource://shelf.cbf305c4-0360-4b70-b854-b1130fa9c363/mg_dripping_rust/mg_dripping_rust?version=c5ff050bceca2ac18df0e635ff892bb9c2b53c01.sbsar")  can't be found, trying to find a similar one
[WARN] <Qt> "[DBG WARNING][Data url converter]" Resource QUrl("resource://project0/HoverbikeTextures?version=1ed102d9dde9ab2e7544b5e7b829fc8e1d4bb8d2.image")  can't be found, trying to find a similar one
[ ERR] <Qt> "[DBG ERROR][Project]" "struct std::_With_nested<class Alg::relocate_document_error,class Alg::relocate_document_error>" save failed (D:/OneDrive/Blizzard Student Contest/Sub Painter Exports/Hoverbike v2.spp, incremental)
[ ERR] <Qt> "[DBG ERROR][Project]" "class std::runtime_error" can't move project file 'D:/OneDrive/Blizzard Student Contest/Sub Painter Exports/Hoverbike v2.spp' to 'D:/OneDrive/Blizzard Student Contest/Sub Painter Exports/Hoverbike v2.18.08.14.19_43.spp'
[ ERR] <Qt> "[DBG ERROR][Main]" "Error Failed to relocate to saved project file 'D:/OneDrive/Blizzard Student Contest/Sub Painter Exports/Hoverbike v2.spp' sending event class QShortcutEvent to object SAVE_PROJECT (class QAction)"

Now a few questions :
- Did you try saving in an other location ? (Not in the OneDrive folder, maybe there is a conflict we are unaware here)
- You did an incremental save (CTRL+S) but did you try in a new file (Save As) ?

I haven't tried saving in another area.
Save As... is what I usually use now as it seems to work better.

10
Allegorithmic,

My productivity has come to a complete halt due to Painter going unresponsive after every 3rd or 4th thing I try to do in the application, such as selecting a texture set.

I have cleaned my registry, uninstalled and reinstalled Painter, updated my drivers, and gone through numerous reboots in the process.  Yet Painter STILL has an issue with me doing basic operations.  The crash when saving bug is alive and well too, both at home and at school, which is to say the bug crosses multiple Painter versions.

I hope that you all will start showing some sign of fixing these issues, and stop replying to such posts as this with "have you tried....?"  We've all tried multiple things, probably anything you can toss at us and then some.  I'm not trying to be rude here, but this kind of performance, lack of fixes, and the incessant placing blame on the user is what kills apps by turning them into one that is completely and utterly useless!  You have competitors, but I'd like nothing more than to continue to use Painter as my go-to texture app.  Yet my faith is a bit low when the last post addressing this blamed nVidia drivers, and no update has been posted on this since May.

11
Substance PainterSubstance Painter - Technical Support - Crash during save
 on: August 22, 2018, 02:36:14 pm 
I have this happen at home and at school (as do my other classmates, across multiple systems).  The one thing I found was that since it states it can't find the file, I just do save as... then double click the actual saved file and say yes to override it.  Save versions now and then too, just to be safe.  I just put v2, v3, etc. at the end of my file names.

12
The PERHAPS fix, which is to say Painter seemed to work better but only for a while....

1. Uninstall Painter
2. Remove registry entries (Press the Windows key and type regedit then enter) for Allegorithmic and make sure the Painter folder is deleted out of your Program Files folder.
3. Run CCleaner's Registry Scan and delete ONLY anything that shows up for Allegorithmic
4. Update your video drivers (this seemed to be the big one for me as 1-3 above only seemed to make Painter run a little better but still have issues, but this seemed to really make Painter act better.

Make sure to reboot after all this. Only then should you reinstall Painter, and then reboot again after the install before USING Painter.  If your experience is the same as mine, you'll get maybe a couple hours of good performance before Painter goes right back to being unresponsive.  Best of luck!

13
Jeremie,

Sorry about the confusion as I meant 2018.2.1, not 1.2.

I might have fixed my issue, but only time will tell. 

1. Instead of just reinstalling again, I took the time to scan regedit for folders with "allegorithmic" in it.  Oddly there were none.

2. I did a registry scan with CCleaner and it found some (CCleaner is the hero once again!).  I deleted anything that Allegorithmic related. 

3. I then rebooted, reinstalled Substance Painter (deleting the old Allegorithmic folder in C:\Program Files first), and rebooted again. 

Clearing out the old folder and all the registry entries seems to have at least sped up the speed of Painter.  The sluggishness is gone, we'll see if the crashing continues though.  More on this story as it develops.  :P

14
2018.1.2 as well.  Awaiting them to sell to someone else who can actually make this program A. run without going unresponsive and B. stop the crashing when trying to SAVE!

15
I just updated my post.  Its 2018.2.1.  I'll send a log file later today, whenever the next crash happens.  Thanks Jeremie.

Pages: [1] 2