Show Posts - andr1

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - andr1

Pages: 1 [2] 3
16
oh would be super interesting to see how you'd approach it, Vincent!  ;D



17
Hello,

I think that the "align along spline" tool is not currently doable via FX-MAPS.

My idea was to draw a thin red curve (1 pixel wide), apply a pixel processor in order to get the individual position of the red pixels and store those values in a 2 dimensional 'array', set to be used by an FX-map iterator that would assign the position of the iterated patterns according to the array of positions of the red pixels.

Problem is that you cant build arrays of values in Designer, right?

18
I was trying to reproduce this photograph inside SD:



Biggest challenge to me, is to reproduce that sequence of eroded lines.
I find myself struggling when I tried to align those lines. They seem to be aligned according to a curved spline (or an arc if we want to simplify).
How to reproduce this very specific alignment?

I tried to use Splatter Circular: I set it non-tiling, set center orientation to true, and tried to increase the radius a lot, in order to obtain a gentle curve, but the problem with the splatter circular is that it has no general offset for the x and y position. So I cannot re-frame the lines as they're are progressively pushed out at every increment of the radius.


Beside the Splatter Circular, I can think of two other ways:
1) Use three or four tile generators to produce a sequence of vertical lines, mask and blend them together, apply different transf nodes to each, offset them and slightly rotate them (brute force, not elegant, but effective maybe?)

2) Use an iterator inside an FX-Map (could be a long and tedious setup and I don't have much experience with Fx maps)

Do you have any suggestion for this specific case?


And more in general, what would be your approach to dispose shapes along a spline inside SD?


19
update:
A restart fixed the problem.

But whenever I try to open the project I was working on it crashes again.

I've attached the project file

20
I was working on a substance, and I tried to open a new 3d window, and SD got immediately stuck and eventually crashed.

Now I'm not even able to restart SD, as it crashes every time after it partially loads the interface.

Any idea how to fix it?


I'm working on a bootcamped Win 7 and gtx 680.
 

21
Thanks Nicolas,

Given we're already speaking about it, I'd take the chance to ask a question about the Tile Sampler and Tile Generator nodes.

I'd like to use the Max(lighten) blending for tiles, in order to obtain something like this:



But this blending type is only allowed on the "blend node", as far as I can understand.

In fact if I set the blending mode to "MAX" in a "Tile generator color", I get instead something like this:


 

Is there a way to use the Max(lighten) blending for the tiles of a tile generator (or tile sample)?

Thanks again!

22
Hello,

Maybe the dumbest question, but I'm not able to find a simple way to scale up an image basing the intensity on a grayscale map.
Something like the warp effect but with scale.
Any idea?


Alternatively, I'd like to apply a per-tile scale to the tiles of "tile generator", maybe using some formula that take in account the index number of the tiles (E.g. scale up to 150% tiles with index number within the 0-55 range)
Should I use FX-Maps to do that?


thanks!

23
Hello,
Hello Urenze,
thanks for pointing the polycount forum out.

As NicolasW suggested in the  polycount  discussion  ,
I tried to delete the whole "session" directory/key in the Registry under "HKEY_CURRENT_USER\Software\Allegorithmic\Substance Designer\5_x\".

Now Iray seems to work.

cheers

24
Hi Nicolas,
I tried to switch Iray computation to CPU, without resolving the problem.

Also tried to switch to SSE2 engine, just in case.. but still pinky pink.


(forgot to mention that I've the latest Nvdia drivers installed)

Thanks,
Andrea

25
This is what I get regardless I tried different settings on Iray.
The render seems to compute (I can see the noise getting finer and finer), but it returns this deadly pink color.


Any idea why?

I'm working on Win 7, running on a bootcamped 2009 Mac Pro.
Geforce 680gtx, 4GB


26
cool!  :P
take care

27

Cool! Glad that helped. Also, you should think about replacing the fx maps in the sbs with the splatter node. You can pretty much get them same effect but much less heavy on computation. It will be very fast with splatter node.

Cheers,

wes

Sure Wes, I'm going to give it a try! Really curious to see the performance difference in UE (-:


Hey nice grass but you shouldn't listen to French people on Youtube 8)

If you want to stick with FX maps, another solution to be more performant would be to generate the grass in two steps : one Fx map (or tile sample or splatter) of more or less 30 strands (without touching the borders) that you plug to a Fx map and iterate 30 times again.

It avoids to have a 1000 costly FX map. Furthermore, even if a single strand occupy a tiny amount of the texture space, you pay for the full price if the input in the FX map, do the technique above should be way more efficient.

If I have time, I am going to make a small third "optimization" video to explain this.

hehe glad to catch with you in the forum too, Vincent! :D
Anyway, your solution sounds like a good compromise. And the given explanation is already pretty clear.

Beside a video tutorial about it, I would be much more interested in a tutorial where you rush quickly over some different examples of  FX-MAPS. Like a showcase of the possibilities. I bet one can do pretty different things with FX-MAPS.

Also, ideally in a part two of the tutorial, it would be pretty useful to know how one can obtain the same effects outside fx-maps (like Wes showed with the splatter) and point out the limitations and differences of both way to do the same thing.
This would be super interesting to learn better this software!

But of course take it as a kind and polite suggestion. It's not a request (-:


cheers, guys

28
You're the man!
I've increased the number of cores to 12. Now it's working (still laggy in the response time, but working)

Anyway, I will also investigate the splatter solution, as you suggested.

thanks again!

29
Hello Wes, thanks for the fast reply.

The long computation could be due to the two FX-MAPS (that iterate thousands of items) ?

I attached the sbs for your scrutitiny.

30
Hello guys,
I've followed the excellent tutorial for grass creation from Vincent Gault but I have some problem working with UE4 now.

After I import the sbar in UE (4.6.0 and 4.7.5 share the same issue) I'm able to modify the exposed parameters just once, then the material doesn't update anymore. Moving all the sliders try to do further modifications to the exposed parameters.

I'm sure I'm missing something (probably because I'm really new to this workflow).
I also tried to search in the forum, without any success.
Would you be so kind to give a look to the attached sbar file?
Thanks!


Anyway, the sbar works in Cinema 4d, and I'm able to use the sliders and change the parameters, however it needs a concerning high amount of time for the modification to take effect.

Pages: 1 [2] 3