Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - volker

Pages: [1] 2
1
I bake displacement maps only very rarely, so I have almost no experience in that regard.

I have modeled several patches (sewn onto clothing) in ZBrush, and added seams to them using separate geometry. Now, I would like to bake a displacement map onto the lowres version of the patches (that don't have the seams as separate geometry, I would like to bake the seams into the displacement map).

It kind of works, but the displacement map that Designer creates looks strange to me. It has a grid-like pattern to it that doesn't look correct to me.

What could cause this? How do I eliminate this grid pattern?

2
Substance PainterSubstance Painter - Feature Requests - Link values
 on: August 28, 2020, 11:40:03 am 
Example: Lets say I have a logo that I want to apply to an object, I put it into the base color slot of a fill layer, and select 'planar projection' as projection method. Then I use the manipulator to position, rotate, and scale the logo into place.

Now, I would like to put the fill layer with the logo in it into a group, apply a mask to the group, assign a fill effect to the mask, and put a black-and-white alpha image (that fits the color image of the logo) into the fill effect to mask away parts of the logo in the group.

How do I fit the alpha image/ fill to the logo in the other fill? All I can think of is to copy each value in the projection settings manually from one fill layer to the next (9 values total) so both (planar) projections match up. Just to repeat the process if I need to change something.

This is tedious work. It would be very helpful if you could link certain input fields together. The possibility to press a button, and have the projection settings of one fill layer copy all values of the projection settings of another fill layer (or fill effect).

3
I'm having issues with a scene involving color selection effects. The scene has several objects in it, created using the new UV tile workflow (9 UDIM tiles).

I have a separate group/ folder for each object in the layer stack, each group masked using a color selection effect.

I'm duplicating a group (with fill layer in it + color selection effect), remove the (single) color assigned to the color selection effect, try to select a different color. With a certain amount of groups in the scene (about 8 groups + color selection effect in the layer stack right now), this crashes Painter almost every time I try to select a new color in the viewport.

It seems to work when I first pause the engine computation, select a different color in the color selection effect, then start the computation again.

Can someone confirm this? Bug report submitted.

4
Pressure sensitivity doesn't work for me in 2019.3. Activating 'Pen Pressure' for 'Size' or 'Flow' in the brush settings does nothing. It doesn't work for the older Painter brushes, and it doesn't work for the new PSD brushes.

No such problems in other applications.

Intuos4 + newest wacom driver, Windows 10.

Any ideas?

5
I have a really stupid question about exporting a SBSAR file from Alchemist, importing that into Painter, and about tiling. I have never used Alchemist before, so forgive my ignorance.

If I import the SBSAR-file into Painter, assign it as a material to an object, and then tile it (increase UV scale), the tiling becomes really apparent the more I increase the tiling. I was under the impression that the materials were generated procedurally, meaning it would be possible to just have the material generated without tiling in all directions infinitely.

That is incorrect, right? I have whats in the current view in Alchemist as a texture and thats it, and can only export exactly what I see there on the square plane, and tile that. It is not a somehow generated 'tile-less' material, like e.g. a procedural noise that can be tiled without the tiling becoming visible. If you understand what I mean...

6
Substance Painter Live link (Xolotl, version 1.0.0.81 + Painter 2019.2.0) suddenly doesn't work anymore with Maya. It did work flawlessly, but doesn't work now on the same system.

I can send the mesh from Painter to Maya without problems (clicking the 'Send mesh from Source' button), but when I create the textures using the plugin, nothing happens in Maya. The textures are exported correctly into the specified directory, but no material is created in Maya, no textures linked, no error messages.

Modo doesn't work at all, I can't even send the mesh. When I try to send it, the plugin window in Painter just gets unresponsive, and I have to kill the entire application via task manager.

Plugin in installed correctly as far as I can tell in Painter and in Maya/ Modo, have repeated the installation multiple times already.

Newest plugin version (for Blender 2.8 yet only) works.

Maybe someone could give me any hint what the cause could be? I'm aware that there isn't much to go on here, but it might have happened to someone else. Thanks!


7
Model in the viewport looks really blurry to me in the newest Painter version, like it is rendered in Full HD resolution on my 4k monitor (edges looking aliased/ textures blurry). Any new setting I might have missed?

8
Substance PainterSubstance Painter - Baking - AO bake looks faceted
 on: July 29, 2019, 04:01:34 pm 
With the new Painter version 2019.2 the AO bake looks faceted when baking from a highres model with smooth vertex normals. Can't be right.

9
I have been testing the Substance Painter Live Link plugin for some time now in combination with Maya + Redshift, which works great and is a real time saver.

A colleague of mine is setting up objects with materials exported from live link in a real production environment now, and has come across an issue.

In the texture settings it is, for some reason, not possible to access the color management features for each of the textures connected to the shader (setting something else but sRGB). This leads to washed out colors in rendering.

He can re-connect the texture manually, which gives again access to the color management, but this defeats the purpose of the plugin.

Is there some way to make the color management for each individual texture accessible by default in the plugin/ the redshift shader in Maya?

EDIT:

There is another problem related to tangent space normal maps - wrong redshift node is connected to the shader, leading to artifacts in the rendering.

10
I have a character with a scarf, and am using the 'Fabric Knitted Sweater' material that ships with Painter as a base, which works quite well.

Now I'd like the scarf matrial to have stripes, and I'd like the stripes to follow the knitting exactly. I could paint a mask of course, which I would have to re-paint each time I change the tiling of the knitting material.

So I thought it might be best to integrate the stripes into the material directly so the details of the stripes adjust accordingly when I adjust the tiling of the material. I can export the material from Painter into a SBSAR file that I can open in Designer, but I see no way to edit the material details. I can only adjust the exposed settings I can access from within Painter as well.

I'm quite a Designer noob unfortunately, so the answer to this question might be/ probably is obvious. Is there a way to edit the actual graph of a material that ships with Painter? Or is this locked somehow? How would I access the graph in Designer?

11
I vote for a lattice deformer (like in Mari), or at least a liquify tool, and project-through for projections.

Meaning, a single projection projects all through the model in one go, front, sides, and back side. Very useful e.g. when creating masks, e.g. stripes going all around the model. Right now, I can only paint them manually (very tedious), or go to 3D Coat for this task and import the texture into Painter.

12
There are situations where you actually want/ need a clean, visible seam (e.g. https://forum.allegorithmic.com/index.php/topic,24299.0.html ). The new seam padding in Painter 2018.1 undermines the possiblily to create very clean seams e.g. using the UV chunk fill tool on a mask. Where you would get an absolutely clean seam prior to version 2018 you now get a very fuzzy transition. This is very useful in some situations because seams are hidden, while being very counter-productive in other situations where a clean, visible seam is actually wanted.

There should be the option to turn the new padding off.

13
There is something awry with the viewport navigation/ camera zoom/ camera translate in Painter 2018.

I'm using a Wacom Intuos 4 tablet, with camera translate mapped to 'ALT + middle-click' and camera zoom mapped to 'ALT + right-click' in Painter.

When I actually try to navigate in the viewport, this is messed up somehow. 'ALT + middle-click' zooms the camera view instead, and 'ALT + right-click' translates the camera.

This is very, very annoying.

14
I have textured a couple of objects in Painter and exported the textures. The objects will be rendered in XSI/ Redshift, and now a co-worker told me about strange normal map artifacts that I did not notice before. They are not visible in Painter.

I checked the textures in Modos native renderer and Vray, the artifacts are visible there also.

What is causing those artifacts? Normal texture should be completely smooth, but there is some kind of stepping visible.

EDIT:

Exporting the normal map in 16bit seems to solve the problem. Should this be the case? I'm pretty sure I have always exported normal maps in 8bit in the past.

EDIT 2:

I have noticed that in Vray the 16bit normal map only limits/ lessens the effect. Artifacts are only visible in GPU CUDA mode though, when using the CPU renderer there are no artifacts visible. Strange. Seems to be a problem with GPU rendering, not the maps themselves.

Any idea how to remove those artifacts for Redshift (GPU only)?

15
Substance PainterSubstance Painter - Discussions - Temporary smoothing (Subds)
 on: December 06, 2017, 10:28:32 am 
How do you cope with the fact that you cannot subdivide (subdivision surfaces) the mesh in Painter/ Export the textures with smoothed UVs?

I often have to texture models that will be rendered in Redshift, and have to be converted to subdivision surfaces in XSI to make them look smooth.

In 3D Coat for example you can temporarily subdivide the model upon import which counteracts the problem to a certain degree that a textured low resolution model will lead to texture distortions in the rendering app when that model is converted to a subdivision surface.

What do you do about that? Subdivide it before importing into Painter? That distorts the UVs in certain areas, and can lead to stretched/ distorted areas during texturing, especially at the UV seams. I have in some cases imported the Painter textures into 3D Coat and fixed the distortions there.

Do you just have to live with a certain degree of texture distortion? Create the model with medium resolution in the first place so distortions won't be as obvious?

Pages: [1] 2