Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - btenorio77

Pages: [1]
1
Hello, I just downloaded the 30 day trial to see if Substance Painter is something I would want to use. I modeled a Fire Hydrant, and baked the normals onto a lower poly mesh to give beveled edges. It works great in both Blender, and Unity. However, In Substance Painter, the normals are not displaying correctly.  I went through this Tutorial https://www.youtube.com/watch?v=7DQZV9vOQpI in which it said to go to "Project configuration", and switch  the Normal Map format between OpenGL, and DirectX. I have tried this, and I see no difference. There also seems to be no difference for if I have "Compute tangent space per fragment" checked. The normals of my mesh itself do seem to be correct, as I have some parts set to smooth shading, while others are set to flat shading.

I don't know if this is related, but in the tutorial when he imported the mesh and normal map, it gets applied automatically. My normal map is not applied when I import it. I have to manually add a normal channel in the "texture settings" at the top left of the screen, and apply my normal map in a fill layer on the right, after checking the "nrm" button in the material.

Correct imported mesh normals in Substance


Incorrect normal map application in Substance


Correct in Blender



Correct in Unity


I bet I'm just overlooking something really simple.

Pages: [1]