Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Smoluck

Pages: [1] 2
1
Hi,  dear fellows.

I ' ve created a graph where i use a Pixel Processor to sample the RGBA value of the current image input.

Now i want to use that graph in another substance, but my problem is that graph didn't output the RGBA Value of the Pixel Processor. I mean i can only expose Input. not Outputs ?

2
Hi.

I've installed the new 2018.1 release of SD.

And now as i load an old graph i have some issue in the package.

Maybe those error where there before on 2017.2.X but I'm wondering how i can select and fix issue by reading the console warning. Do someone can help me find a process for debugging ?

If i double click in the Console, SubDes didn't show me the problematic node in the graph. so how i can quickly fix those issue ?

one of the typical error in it:

[Cooking]Size out of bounds:
                       Size: 8192x8192
                       From Graph: pkg:///Stamp_Map?dependency=1307150960


[WRN][1868][Cooking]Can't find subgraph input:
                       Input identifier: Mask
                       Subgraph Url: pkg:///difference?dependency=1290776863
                       From Graph: pkg:///ColorPicker?dependency=1290776921


3
Hi, i wanted to do variation of an SBS file, and i can't figure out where is the setup for installing tthe toolkit. i can't find any link in the documentation webpage, excepet the Python installer.

where i can i get it (i use Substance Designer Indie)

best regards, A Team

4
Hello,

i'm owner of substance Designer 6 and Painter 2 indie license (No Subscription).

And i've notice that i can install and use Designer 2017 and get the free license (probably because i've upgraded designer recently on 15/02/2017), there is no license or software line for Painter 2017 in my account license page.

Is that normal ?

If not how can i update Painter also to 2017 release ? Actually if i go to my account page and click on Download/Buy and then Indie License. And click on If you have Substance Painter 1.x, upgrade for 50$ (instead of $75). (i got the 2.6)

It goes to that page, https://www.allegorithmic.com/buy/upgrade, so i can't find any 50$ upgrade possibility.

As i don't want to miss the 50$ upgrade till the end of the month. what can i do ?

best regards, Franck

5
In the render preview and the advanced viewport on Modo 11.1 RC0, it looks like the tangent vectors are not supported the same way

in modo


in Substance Designer 6.0.4


Have you tested that Wes ?

6
Hi, i've tested today the Substance Plugin 2.4.0 for Modo 11 (tested on 11.1 RC0 also). what i see it's that a boolean attribute exposed in the graph can't be set inside Modo.

Is there a limitation list of the attribute type that we can use in Modo ?

7
hello,

I'm actually working on a project, where i need to create texture for many different fbx assets, as it's a large amount of meshes, i've decided to create a structure robust and simple in terms of tweaking (switch from baked maps of Mesh A to B and so on). Things are i'm working with 4K Maps all the time, and it looks like SD can't get to work as expected ( Tremedous delay for the computing and crash often.

(my PC at home where i'sve setup that, is a last Xeon 8 Core Processor with 64 Gb Ram and a 1070 GTX. The config looks ok to work on 4K texturing, but i'm probably doing this the wrong way.)

So I've decided to create a new substance and create a folder for every bake maps related to their own fbx mesh.
Regrouped in folder MainBody_partA , B, C, and so on....



Then i've created one graph in the "custom node" folder to organise in a single node (0_BakeMaps_MainBody) all my different bake maps from all the different sets of assets. This way with an exposed Multi Switch (and Multi Switch Greyscale as well) input, i can select witch bake i want to render for the final texture this way.

in this exemple i got 4 maps on the left side related to mesh A B C & D, then Multiswitch node and then output.


On another graph (1_IDSelector), i've created a simple setup, with a material selector, and exposed the "pick color" to let me create the mask that i want in a simple and only one node in my Final Graph.



Then i've created the Final Graph "Mat_CEP02_MainBody" where i load my 0_BakeMaps_MainBody to link all my baked maps and also 1_IDSelector in the Blue Frame, to create on demand Mask for the related Material.
(At first I've instanced my 0_BakeMaps_MainBody Node multiple times all over the graph, and that look's ok , but for optimization, and to fix the crash that occurs a lot, i've decided to use only one node at the bottom)



Every output then are 4K as the main iput are 4K also. But at that time if i didn't suspend the engine, it crash at the computing of the Mat_CEP02_MainBody.

Of course for optimization, i've disable output(s) Computation in the Attributes of the custom nodes, because i only use them into the final graph.

At some point i've reach around 44 GB of ram usage for SD , until it crash..... It sounds weird. Is that wrong to do this way ?

8
Hello, I 'm currently having fun with Substance Designer ability to create additional (utilities) graph that i can use in the Final output graph. But then after creating those graph.

i'm worrying about this for now, because at some point i'm computing a 4K map out of all those custom nodes, and SubDesigner crash sometimes back to the desktop. so i want to be sure that i'm working in the good way by checking and get the control on the processing line.



Here my Final Output Graph is Mat_CHE01_MainBody at the top of the list.

Inside this graph i use other graph like the one that regroup in only one node all my baked maps (stored in Resources as linked bitmap) in a convenient way (0_BakeMaps_MainBody) and other graph for Pattern and such into the Custom Node Folder (1_IDSelector for exemple use the 0_BakedMaps_MainBody node and a Material selector in order to ouput any mask i want from my ColorID).

Is there some ways i can define that i want to compute first my main Baking Graph Node where i feed all my baked maps, then move onto the utilities Node Graph that i use on some part of the models, then Compute de final Output that use those utilities node.

I know that Designer work as usual from Input to Output, but so if there is any problems inside my graph, how can i find the graph that got bugs or mistyped value that create errors ?


9
Hello,

I don't know if someone have already reported this, but SubstanceDesigner 6.0.1.594 is really slow under my PC.
5.6.2.533 have no issue at all opening the graph on my PC. and it's really not sluggish as the 6.0.1 (around 1 or less frame per second). with the 6.0.0 build19985 it's fine but less fast as the 5.6.2.

Is that related to FBX 2015 exported from Modo 902 sp3 ? I just got a 2K map and 408 Polygon. It sounds weird.


   
Quote
Windows 10 Professionnel 64-bit
CPU
   Intel Xeon E5520 @ 2.27GHz   45 °C
   Gainestown 45nm Technology
   Intel Xeon E5520 @ 2.27GHz   44 °C
   Gainestown 45nm Technology
RAM
   30,0 Go Triple-Channel DDR3 @ 531MHz (7-7-7-20)
Motherboard
   TYAN S7002 (CPU 1)   46 °C
Graphics
   DELL U2410 (1920x1200@59Hz)
   DELL U2410 (1920x1200@59Hz)
   ASPEED Technology Carte vidéo de base Microsoft (ASPEED Technology)
   4095MB NVIDIA GeForce GTX 970 (ASUStek Computer Inc)   31 °C
   ForceWare version: 376.53
   SLI Disabled
Storage
   238GB Samsung SSD 850 PRO 256GB (SSD)   33 °C
   931GB Seagate ST1000DM003-1SB10C (SATA)   30 °C
   1863GB Intel Raid 1 Volume (SSD)   33 °C
Optical Drives
   No optical disk drives detected
Audio
   Creative X-Fi Audio Processor (WDM)

10
Hello, I' done a little test creating a blend node and 2 coors to see a text inside unity. The Alpha of the Blend node is define by the new TEXT Node from Substance Des 6.
But it seems that Unity 5.5.0 can't read it correctly. i can open the asset into unity.

Does i've made a mistake or does it's nort implemented now ?

In the Graph InputParameters, i've add a new String variable as a Text to change the text inside unity. And define the same input Identifier inside the Text Node.


11
I'm facing a problem on "Tile Random" custom function.

As i want to control the Tile on X and  Y and link those Variable to other Tile random node in my graph, i've made a function into the X Amount, but i can't find a way to set just a float to be the Output. It's weird.

No problems at all on the contained FX map in the graph.

Create a new graph,
create a Tile Random,
create an empty function inside the Instance parameters / X amount
create a Float,
then right clic to set it as output..... you should get a grey answer from SD.

do i'm doing this wrong ?

12
Hello dear Dev.

I'm working a lot on Substance Designer since one week, on every day. and i got some question for you.

  • Is there a way to link an attribute for exemple the settings (Instance Parameters : X and Y amount) of the Tile Random Node for multiple duplicated node as this one ? I got few of them in my graph that should use the same amount. (instead of changing every amount value for every Tile Random node)

  • I'm pleased to see the support of SBSAR package inside Unity, but it look like i missed some setup. My Main UV set is used for the Albedo/Normal/ Spec/gloss actually. It's working great in Unity but now if i want to add an Input file to the graph it's always using the UV set 0 instead of the one i've made for the damage/curvature pass or Ambient Occlusion Pass.


Here i can't define the UVset for Input_AOmap and input_CurvatureMap. Is there a workaround ?

Here in Modo i got 2 UVset, with different Texel/meter value.


By the way, i really like Substance Designer.

13
Hello,

Did you've got some errors like this at UV tile border, when generating maps from an Sbar material in Unity (5.3.3f1) that was made in SD (5.3.4) ?



i've made this sbs from scratch using the Spec / Gloss shading. I didn't see any problems at the border of the plane in SD.

what do i need to check first ?

14
Please be careful. Don't update you Windows 10 OS to the last build from November: Build 10586.3

Because it make SubstancePainter unable to start. Everything is OK with SubstanceDesigner

When you launch it, it will tell you that it couldn't load MSVCP110.dll and MSVCR110.dll. Even if you get the old files from your windows.old directory (win 8.1 Pro) and paste them into c:/Windows/syswow64 it wouldn't start.

If you'll have any workaround to solve this, please reply.


EDIT: Solved.

1___You'll need to uninstall any distribution of Visual C++.
(in my case distrib 2005,2008,2010,2012,2013 in x86 and x64)
2___ Check if there is still MSVCP110.dll and MSVCR110.dll in your c:/windows/syswow64
3___Reboot
4___Install back those distribution of Visual C++ from the oldest to the latest 2015:
5___Enjoy SB Painter !

Here is the link for the Redist Setup in x86 & x64:
https://www.microsoft.com/en-us/search/DownloadsDrillInResults.aspx?q=Visual+C%2b%2b+Redistributable+Packages+for+Visual+Studio&cateorder=1_5_2_3&sortby=-availabledate&first=11

15
Hello.

Do there is a way to clean all Bitmap sources that we have loaded inside a project ? I'm unable to delete/close bitmap source file in the "Textures" Shelf. So with this, the spp get bigger and bigger.

Is that a bug ? Or do i'm processing this wrong ?

Pages: [1] 2