Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - n00bPainter

Pages: [1]
1
Hi everyone. Wondering if anyone can help me out with an issue I'm facing. I am in the preliminary stages of modeling a low poly version of a shoe for use in a game engine (hi poly is done). For now I've just used an automatic unwrap to test the bake, and I'm getting a nice bake for the base of the shoe that I'm happy with.

The problem is that I have a bunch of other objects to model for the shoe (such as buckles, straps, etc), and when I combine the objects into one mesh, I'm finding that things like the straps are affecting the bake of the object beneath it (which I don't want).

I'd like to have all of the objects sharing one UV space / texture map. I'm assuming there is a way around this that I haven't learned about yet? See attached screenshots. In the second image, you can see how the strap is baking onto the base of the shoe. I'm basically wondering if it's possible to tell substance painter to have the objects ignore each other during the bake process so everything stays on one texture map but each object bakes individually.

Any suggestions are appreciated.

 


2
Substance PainterSubstance Painter - Baking - Garbage Bakes
 on: June 27, 2019, 12:56:36 am 
Hey all. Wondering if anyone can point me in the direction of how to fix this? I've watched a million tutorials on baking maps in substance painter and they all use things like cubes or planes. I'm trying to bake maps for a shoe. The model itself is broken up into separate meshes (so the laces are each a mesh, the straps are each a mesh, the buckles are each one mesh, etc etc). I did this to make painting it easier, or so I thought. However, now I can't seem to get a decent bake to save my own life.

I have created the high poly version based on the low poly by just dropping in edge loops to hold the form, and then converting the model to smooth mesh preview (I'm using Maya). I've tried both exporting everything as a single object for both the high poly and low (FBX) to exporting everything combined, and fiddled with all the bake settings with no results.

Does anyone have some suggestions for best practices here or can steer me in the right direction as to what I'm doing wrong? I need to get a solid bake before I can move on with anything else and so far it's eluding me.

As you can see, the buckles aren't baking properly, the laces are projecting onto the tongue, and that's just this one region. This was also the best result I was able to achieve, but I don't consider it acceptable as I will need clean maps to paint on. I did try exporting a slightly scaled up version of the low and high to use as a cage, but neither produced better results.



For Reference, this is what the low and high poly look like in maya (I've separated the high poly into different material groups in the hopes of speeding up the painting process):





EDIT TO ADD:

Interestingly, by deleting all the buckles and straps and laces etc from the low poly model, I get a perfect bake, which is great for a low poly LOD; but I'd still like to know if there is a way to keep those meshes for a different LOD and get better results from the bake.


3
Substance PainterSubstance Painter - Discussions - Baking won't work
 on: September 07, 2017, 11:36:56 pm 
Hi guys, I am new to Substance Painter. I have a mesh I'd like to generate maps for so I can paint it, but no matter what I try, I can't seem to get it to bake properly.

Sometimes it bakes with anomalies, sometimes it doesn't bake the normals at all, sometimes it just spits out errors. I have watched multiple tutorials and tried all kinds of settings.

I have tried exporting both the low and high poly models as separate objects, as combined objects, as exploded objects with a cage, as exploded objects without a cage, etc etc. I have tried multiple bake and export settings, and nothing seems to work. I'm at the end of my rope.

The low and high poly meshes all occupy the same space in my scene, have their transforms frozen, and their origin set to the center of the scene. The low poly mesh is completely UV'd and there are no overlapping shells.

I have made sure to name every single poly (whether combined, separated, or exploded) with _low and _high as appropriate. I have also made sure to enable triangulation on the FBX export for the low poly models, and also tried triangulating the model in maya first.

Nothing seems to work. The model is for use in the unity engine, so I have selected that as a preset when importing from maya to substance.

I am using maya 2015 at the moment. Is there any chance someone can take a look at my scene and recommend how I can improve my results here?  :'(


Pages: [1]