Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - JHarford

Pages: [1]
1
Well done! That's nice work.
Sorry it's been quiet for you on the forum. The technical support subforum seems more active.
I'll dig into this and see if I can come up with any ideas.

2
What would be the correct approach to skipping pixels in the pixel processor. Eg only apply to every third pixel
Thanks

3
Hi Nicolas,

Thanks for the information, super helpful!

I noticed when using this method that it works great for darker colors, but lighter colors have a lighter halo around them. Is this expected or could my setup be incorrect ?

I'll mockup a simple comparison node scene and post the graph to make sure i'm on the right track

Thanks

4
To compensate for this for now, I'm going to build a graph with the splatter node instead of the tile generator with several inputs as the splatter node does what I require and is more performant. It also does not support alpha blending correctly, but i'll use the alpha split and merge method detailed earlier.

5
Thanks Eggfruit,

The alpha split method is definitely handling the situation at the moment at the performance darg of having an aditional Tile Generator.

Your method of selecting a simple background color is definitely a nice alternative ( and cheaper ! ). It won't work in this situation where the colorvariation across the tiled object is important but in other situations would be ideal.

With all this solved, the next issue is the tile generator 'Position Random' value is not consistent in the Color & Grayscale Tile Generator nodes. ( I'm guessing it uses a different seed ) so the tile generator alpha split method can't be used if you require a randomized pattern ( rather than in rows ). Unless there is another way to vary x/y position randomly per cell in the Tile Generator.

The Tile sampler / Tile sampler color , has a single 'Position Random' parameter and this is consistent across both versions. So while it's much more expensive, it works.

6


I created a function node graph to split and combine, exposed the parms of the generators and linked them.

7
The only way i've found of handling it so far is to run two seperate Tile Generators
One for color, one for alpha.Then use the alpha as the opacity input for the blend
Is this standard practice?

8
Hoping you can help with an issue i'm having running a node through a Tile Generator Color node.
Previous to the Tile Generator Color , the pixels of the alpha are colored/brown. After running through the TGC they are grey/black.
Is there a way to keep the original or ensure the alpha is processed correctly.
Is there a specific method to ensure a clean alpha/transparency when adding a colored feature to another map. Eg - a coin on a table, a mole on skin, a decal on a texture.

I've included an image to make things clearer ;




Thanks!

9
Thanks Eggfruit for the concise explanation, all working correctly now !
Hopefully this gets fixed in future builds.

Cheers

10
When using a random function inside an opacity variable, the random function simply increases the opacity rather than choosing random values.
I've tried hooking up the random seed, or changing global seed but the same occurs. The higher the random seed, the higher the opacity.
Am I doing something wrong ? I'm trying to get the global random seed ( or local ) to randomize the opacity setting in a node graph.

Pages: [1]