Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - unity2k

Pages: [1] 2 3 4
1
I create a Substance using B2M 3.0.1, save it and Export with Dependencies.

Copy the Substance to another drive of another user and copy to our SVN.

Try to open the .sbs from the local drive first and get the message "Do you want to specify a new location for 'sbs://Bitmap2Material_3_UE4.sbsar'?"

If I click no, I get a Ghost Graph.

If I click yes, I have to go to the Program Files/Allegorithmic....directory and point to the B2M UE4 node and save the graph.

It then remembers the path and on subsequent openings the .sbs opens correctly.

Same with working from SVN version.

This is a rather huge problem because it means we would have to "repair" about 1500 Substances for 6 different users - well we can't do this 9,000 times.

2
Substance Integrations - UE4 - 4.5.1 SD Plugin for UE4
 on: October 28, 2014, 07:12:06 pm 
Josh, please update the SD integration for UE4. Epic released 4.5.1 and stupid me updated, problem is there is no backing out of this version down to 4.5.0

3
Substance Integrations - UE4 - SD UE4 Plugin Requirements
 on: October 28, 2014, 06:51:31 pm 
Yesterday Wes demonstrated the "simple" dropping of the UE4/SD plugin into an Unreal Project as though it were so simple, neglecting to point out that the user must work with a Basic Code template and have Visual Studio Express for Windows Desktop installed.

Well I don't have to do this for Speedtree, when will we see a simpler implementation of the Substance Plugin that doesn't require VSE and the need for new a new plugin every time Epic updates to a new point release?

4
I cannot double click an .sbs file in Library view and have it open in Explorer.

But I CAN double click the same file from a Windows Explorer and have that .sbs file open in the SD Explorer.

Instead of me having to right click the Substance in Designer and click the file location which launches a Windows Explorer so I can double click the .sbs and have it open in the Designer Explorer, I'd like the easier more logical ability to just double click the .sbs in Library and have it appear in the Designer Explorer.

5
Substance DesignerSubstance Designer - Feature Requests - Explorer Request
 on: October 17, 2014, 08:16:12 pm 
In the Explorer dialog I have the opportunity to Save, Save and Open in Player, and Publish.

I would like this bar to be configurable so I can have it offer the option to Save As, Export with Dependencies, and Publish

6
In the Parameters window we have the option to select an Icon, it would be great if you guys had the option to generate the Icon right next to the "Select Icon" button. I'm asking for this because the auto-thumbnail on the Substances I'm creating from bitmaps are frequently too poor for my team to get a good idea of the true quality of the texture.

The attached screencap shows bitmap named ConcreteBase0309 as thumbnail, in 3D view, and in 2D view.....only the 3D View is of a quality that can be used.

7
And so starts the wait for the Substance plugin that will allow us to use our .sbsar's in UE4 4.5 Official!

8
I removed a Path from the Library section in Preferences/Projects and the files are still rendered in the Library. I have to remove the files from the directory on my hard drive so they don't render.

9
Guys,

I'm starting to use the Bitmap2Material 3.0 node in Designer.

1. I want to create a template to start building PBR Substances but I can't choose Curvature as a default in the New Graph dialog

2. The B2M3.0 PBR node has both Height and Displacement, but my understanding is that they are the same, thoughts?

3. BaseColor behaves differently than Diffuse, where can I learn more about the differences?

4. Is BaseColor the same as Albedo?

5. When can we expect B2M3 nodes to have icons and show up in our Material Filters?

6. When will you name the B2M3 nodes differently so it's easier to differentiate PBR from UE4?


10
Having a problem using the Bitmap2Material 3.0 node in Designer while using the Tessellation Parallax shader, my cube is black and white. This relates to 4.5

Update: Tessellation shader is black and white no matter how I feed it......until I feed it a Diffuse output....my bad. Using Base Color as Diffuse produces black and white......sorry guys, I'll learn this sooner or later

11
I can only get the PBR Albedo SafeColor node output to work if the Graph is set to "Standard" display - NOT Material or Compact Material. This relates to 4.5

12
With the Export as Bitmaps dialog I cannot close the dialog with the "X" in the top right corner, I have to click "Close" - or Export

13
I cannot get the Base Color to connect to Diffuse Output using the new B2M3.0 node, the problem turns out to be a bug in the User_Preferences.xml file.

I'm a Database user and with the Library being populated with the Database categories my B2M3.0 node is broken.

Remove the .xml file so Designer builds a new one and the B2M3.0 node works like it should.

So I rebuilt my Library filters (tedious and time consuming) but this way I had a very clean User_Preferences.xml file and the same behavior that stops the B2M3.0 node in Designer comes back.

Btw, the B2M_Light node continues to work under either situation.

14
The B2M 3.0 PBR node for Designer is not connecting the Base Color node to the Diffuse Output on two of my pc's, but it is working for a friend of mine.

I've tried uninstalling and reinstalling Designer, that hasn't worked.

I drag the output from the PBR node to the Output nodes and everything but the Base Color and Diffuse connect. See attached

15
I placed the new .sbsar nodes (from Pro) into C:\Program Files\Allegorithmic\Substance\Designer\4.x\resources\packages - I think that's correct, as there are no instructions in the B2M3.0 package where they are supposed to go.

While I can find the nodes using search in the Library, they don't show up.

Once they are found they are the Icons are not rendered, see attached.

Also, the Base Color does NOT automatically connect to the Diffuse Output. Someone else I know, it works, but on two of my pc's it's broken. I'll try a clean install to see if that helps.

Pages: [1] 2 3 4