Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - mrmongbat

Pages: [1]

Here's a simple way to reproduce the issue I'm running into. A single layer with roughness set to 1 and metallic 0.

Yet when I export the specular map (either through a new preset or for example Unity specular setup preset) the specular map is always grey instead of black. Here's the exported map

I can't seem to get a blacker specular which causes weird washed out look in Unity when using the substance exported maps. (Right example - left is how it should be)

I've tried changing the shader in substance from pbr roughness to various other shaders with no change. I've tried using a level filter, no change.

I'm wondering what I'm doing wrong here?

I've been having some troubles with importing normal maps into Unity 2018 and I'm looking for info.

The export settings in Substance Painter have Unity 5 presets, do they work for 2018?

I found the following official video regarding exporting fbx files for baking for Unity, however that seems to be quite old and as far as I know Unity 2018 does use Mikktspace, right?

So I'm assuming I should use the UE4 method from that video of exporting the FBX without Tangents and Binormals, and enabling "Compute tangent space per fragment" when importing the model to Substance Painter and using the DirectX normal map format?   

In the video he does export with Tangents and binormals for Unity and disables the Compute tangent space per fragment when Importing into Substance Painter and uses OpenGL, that is outdated right?

Would I then just use the Unity 5 export texture preset or do I have to change that somehow as well?

edit: I've tested this a bit, I think something is off:

Tried exporting the model with binormals and tangents and without, tried baking both with "compute tangents space per fragment" on and off.

My results so far:

So basically nothing matters, it always looks the same when I import it into unity except when I turn binormals/tangents OFF in the FBX and enable Compute tangents space per fragment on import into Substance, then it'll create some weird shading artifacts.

I left the Unity import settings at default in all tests, should they be changed in some ways? All cases got very messed up when I played with the import settings. here are the default ones:

Pages: [1]