Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - Cpt.Sloth1992

Pages: 1 [2]
You just need to add a RMA output to your substance in Designer.
Just add an Output Node and set it to "Any". Then channel mix your Roughness, Metallic and AO maps into one RGB texture and connect it to the output. Insie UE4 you can just check the checkbox next to the RMA output in your Graph Instance.

I wanted to turn some 4k maps into a substance for use in UE4, but encountered the following problem:

When I change the output size in the substance graph instance inside UE4 the resulting bitmap is scaled correctly but the content of the bitmap looks extremly blurry, about as sharp as a 256 texture that was just upscaled to 4 k.

The bitmaps used in the substance are all 4k, and when viewed inside of SD, setting the output size to 4k results in an output as sharp as the input bitmap.

I also testet this with substances that don´t have an Input bitmap and they recalculate their content correctly inside UE4.

This happens when using the CPU and GPU engine.

I would guess that this is caused by the UE4 plugin not correctly applying the output resolution to Input nodes.
Maybe it uses the given resolution for the output files size, but does not rescale the input bitmaps themselfs, which results in their 256x256 versions beeing dragged up to the given output resolution.

I attached a screenshot of the Graph, which is pretty much just the input bitmap + Scaling, Tiling and some color tweaking and a screenshot of the Graph and Input Node settings.

I went back to 2.4 and the problems are gone. Something is definetly wrong with 2.5 and 2.5.1.

At the top left corner of the Layer menu, change base color to normal/height and then select your top layer and change the blending mode (top right of layer) to replace.

I am confused as to which way is the best to bake normal maps form a high poly model with the latest version of SP.
I used to get great results by splitting the UVs at hard edges and then giving different smoothing groups to each UV island. How ever, as of 2.5 every combination of smoothing groups and UV seams results in some form of artifact.

I made a simple test object so check how the normal baking behaves in 2.5.1 and here are my results:
(note that there are no errors in the low or high poly model and all maps were baked with default settings + Bake by Name on)

In order: 1. UV seams at hard edges and each UV island has its own smoothing group.
               2. Only minimal UV seams and each UV island has its own smoothing group.
               3. UV seams at hard edges and the mesh has only one smoothing group.
               4. Only minimal UV seams the mesh has only one smoothing group.

Each of these combinations results in different degrees of artifacts, but each of them has one.

          - 1. and especially 2. have visible seams in the normal map at every edge > 20°

          - 3. and 4. have less seam artifacts but result in normal maps that try to compensate the fact that the model only has                   1 smoothing group which results in a strange look when used in Unreal Engine 4.

On the last image, you can see the tops of the test objects. Note that the 3. and 4. model with only one smoothing group have a very "bent" normal on the flat top end of the model while the 1. and 2. produce a very clear seam artifact.

What I want to know is the following:

What is the recommended way of setting up a model in 3ds max for SP?

- One smoothing group total or one per hard edged area?

- Do the UV seams have to strictly match the Smoothing groups or can the two be used independently of each other?

- Can UV islands ignore hard edges if it results in a better, less stretched and easier to work with UV Layout or do they have to have seams at any slightly harder edge, even if it breaks the model into 1000 UV islands?

I can confirm this. Here is a comparison of 2.5 with and without Bake by Mesh Names and one screenshot of the same model baked in 2.4.1.

Note that the results with and without Mesh Names enabled in 2.5 are not completely identical.

Thanks for you Help!
It would appear to me that this is supposed to work, since there wouldn´t be an output selection if the user was not meant to change what output of the material is used by the fill layer.

It would be great if you could confirm that the Fill Effect output selection works when used directly on the a layer, but is ignored if the Fill Effect is attached to the mask of the layer instead this evening. I´d say if that is the case we can rule out a hardware related or local problem.

A workaround that I found which works for materials that have height dependent BaseColors is to go with the basecolor output of the Fill Effect and then simply stack some level effects on top of that to immitate the Contrast and Variation of the actual height map. This gets me kind of what i am looking for, but has the limitation that the basecolor luminocity has to be based on the height and is not a replacement for a working Output selection.

You seem to have missunderstood my problem.

I dont want to replace the Gold with the Cobald, I want to use the Height channel from my substance to drive a mask to blend between two materials.

The Issue lies in the Channel Selection of the Fill-Effect. It alwasy outputs the first output of the material (in this case base color) and uses this as a mask (the medium grey color creates that 50/50 blend between the Cobalt and the Gold). As you can see in the screenshot I attached, the channel Selection of the Fill Effect is set to hight, but the mask is using the base color instead.

So of course the Cobald will "magically" reappear fully if I disable the mask or set the basecolor that is used as a mask to full white. The substance is set up correctly and there is no opacity in this at all. Using a Filter also has nothing to do with this.

Again: I want to use the Fill Effect to get an Alpha from my Materials Height Output, but is allways uses the BaseColor Output as a mask instead. Take a look at this new picture.

This is the case with any materials, including default ones and materials from Substance Source.

So, I don´t want to bump this up a second time, but after two weeks and 40+ reads I´d like to get an answer to this. Can anyone confirm or deny that this is a bug?
The channel selection on the fill layer works fine when used on the fill layer directly, but when used on a mask, the selection is not changing the channel at all.

I noticed right now, that it is not always the base color output that is used, but the first output in the selection list. If I drag a material into the fill-Effect layer that also offers a diffuse output, that output is listed above base color in the output selection menu and is the one that is always used, no matter what I select as an output.

While testing a new material today, I noticed that if I add a Fill-effect to any layer mask and then drag a material into the greyscale slot, SP always uses the basecolor output of the material as a mask, no matter what I selected as an output of the Fill-effect.

I was able to reproduce this with multiple materials including default ones. Here is a screenshot of the layer with the fill effect mask. Note that the output is set to height, but the mask uses the basecolor.

Could anyone please confirm/deny that they got these artifacts aswell? Or am I the only one that gets these terrace like artifacts?

Anyway, I submitted a custom version of the grunge maps, one that lets you blur these artifacts without changing the rest of the grunge maps, to Substance Share and they are currently waiting to be approved.

I took a closer look at the mentioned grunge maps and it seems that in every case the artifacts are caused by a warp. When I added a blur node after said warp with a rather small value (about .3) that blured the steps formed by the warp enought to hide them completely without altering or bluring the rest of the grunge map.

I will just redo the grunge maps and add the blur node for now, but I don´t get why these artifacts were not taken care of yet. They really stick out when the grunge map is used to blend two different materials since that results in a noticeable circular pattern, almost like a fingerprint, as seen in one of the screenshots I attached to this post. It would be rather easy to fix in an update, as bluring them right after they are created by the warp leaves the rest of the grunge untouched.

I noticed that some of the default grunge maps start having artifacts that look similar to those that you get when you use a 8 bit hight map (see attachments) when I use a high resolution like 4096x4096. They are even slightly visible in 2048x2048.
I´ve noticed these artifacts on the following grunge maps: 01, 03, 14 and 15.
This is the case in Designer as well as in Painter. Is there a setting I´m missing or are they supposed to look like this?
I did a clean reinstall of Designer and the new Grunge Maps have the same kind of terrace-effect.

Pages: 1 [2]