Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - annabeck

Pages: [1]
1
I know this is such an old chain but there's just not that much out there about the $time variable and I'm losing my mind. I guess you could say I am still a bit of a novice at Designer. I mainly just don't understand how you apply these functions to the actual parameter/attribute you want them affecting. How do you open up the function graph view. How does the normal graph view connect to the function graph etc.... any info at all about this would be amazing. thank you

2
Did you figure anything out? I have a material (from metal to rusted) that I want to render out the sequence for. I'm fine with using Substance Player and exporting the image sequence maps (and using maya+arnold) but I cannot find a good tutorial about the $Time variable to make this work!!! I wish you could just key attributes in Substance Player...??

3
So I am a coding noob. I've installed Maya 2019 and the Substance plugin. Where should I put the substance plugin folder so that Maya will load it? And do I need to change any of the coding in the files? This is the error I am getting right now:

Warning: file: C:/Program Files/Autodesk/Maya2019/scripts/others/pluginWin.mel line 910: Could not load C:/Program Files/Autodesk/Maya2019/plug-ins/SubstanceMaya/2019/plug-ins/Substance.mll as a plug-in //

4
Thank you so much! Its the 1.4.1 I assume? I saw that update a few days ago as well

5
Best news I've heard all year.

6
I apologize, I realized you would need the actual Substance Designer file to troubleshoot this. Considering my .sbsar file is what does not work...

7
Here is the substance designer file. I realized you would need this to determine why my file won't export correctly...

8
Awesome, thanks for downloading. Have you had any luck? I think I'm going to retry making the material in an older version of Substance D since older materials I have downloaded seem to work fine with the plugin in Maya.

9
hello Galen,
I am using Maya 2018, SD 2018.30 and the plugin should be the most recent update!

10
I just found myself in the same situation as the original poster. Just learning Substance Designer with eye toward using outputs in Maya 2017. Followed along with initial tutorials to create the Rusty Metal texture. I got through the three "Creating A Base Material" tutorials and since the third video ends with publishing, I wanted to see what happened when I tried to take the resulting sbsar file into Maya. What happened was nothing. So I went back to the Substance Designer tutorial site and downloaded the exercise file. I opened it in SD and could see that the graph was quite different than the one I had exported. So I published the exercise file and then tried linking Maya to that. It worked fine. Later I found the "Material Blending" tutorials, which seem to be explaining the differences between the exercise files and what I had created following the first three tutorial vids.

So I think my problem was with the file I first published. I'm writing this as a warning for anyone else who, like me and the original poster, has a problem with the sbsar file from the first vids. I see now what to do to troubleshoot that. I'm still not clear whether that one should have worked in Maya, but I have a feeling it's best to follow the Blending videos first.

When I was getting no result, I came to this forum to see if others had the same issue. What anyone reading this now is seeing is a rewrite of my original "me, too" post.


So what did you end up doing to fix it? Like what had you been doing wrong all along? Because, unless there is another big with the plugin in the even new versions, I am getting the same problem with a VERY simple material i created where i only have one expose parameter that I am trying to test out in maya!

11
Hello.
I am using Maya 2018, Substance Designer 2018.3.0 and the plugin should be a compatible version. I created my own substance material and am trying to load it into the substance node in Maya. it doesn't seem to load at all and when I try to create shading network, I am getting the error:
 "No Substance Output Node could not be automagically connected to the shader node. Please refer to Substance Plugin documentation for outputs standard naming or exit custom workflow"

I've tried .sbsar files I've downloaded from Substance Share and most of them seem to work fine. I read an old forum post where this issue was happening because the current SD didn't work with Maya yet or something. I am fairly new to SD but I followed a tutorial and created a veryyyy simple material just so I can test this out. i only have one input parameter I am trying to test. I was wondering if maybe I have named something incorrectly or if there is a bug. Thank you! (I have uploaded my material.)

Pages: [1]