Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - ollyskillman

Pages: [1]
1
Substance DesignerSubstance Designer - Technical Support - Re: Update Lag
 on: September 05, 2020, 05:21:18 pm 
hmm, I may have spoken too soon.
Its running very speedily in substance player now, but there's is still some lag in designer. Will continue to address errors in the console and will send the graph if I get stuck.

2
Substance DesignerSubstance Designer - Technical Support - Re: Update Lag
 on: September 05, 2020, 05:15:47 pm 
Hi Luca, I just figured it out!
I found the console and there was an error:
[WRN][814][Cooking]ERROR_UNKNOWN_INSTANCE_PARAMETER_NAME:
                   PARAM: RiverNumber

That lead me to this forum post:
https://forum.substance3d.com/index.php?topic=29160

So I deleted the instanced node I thought the missing parameter had come from and dragged it in fresh, reconnected the parameters and its running really nicely now :D

3
Substance DesignerSubstance Designer - Discussions - Re: Locating Cooker Warning?
 on: September 05, 2020, 05:10:49 pm 
this was a godsend, had huge slowdown from this error and now everything is nice and speedy :)
deleting the instanced graph and dragging it in fresh and reconnecting the parameters solved it.

4
Substance DesignerSubstance Designer - Technical Support - Update Lag
 on: September 02, 2020, 12:37:52 am 
I'm working in a fairly large graph made up of lots of subgraphs, and I'm finding that there is a significant delay when making changes to a node, or an exposed parameter. The rendering progress itself is pretty speedy as I went back and made lots of optimisations as I thought this was the problem initially. The slow seems to come from making a change to a slider or node, then there's a 5-10 second wait, then it renders in about 1-2 seconds. I notice the same problem in substance player after exporting. Once I have touched a parameter for the first time, sometimes it will update much more responsively, but that first change always causes the delay. Is there some caching or cooking thing I'm misunderstanding? I've found it hard to find useful info on both those things in the documentation, for someone who doesn't really know what either is :D
Any advice gratefully received as its made the graph very hard to work in and I've become much more reliant on pausing and unpausing the substance engine while making changes.

Pages: [1]