Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - kashif.c.riley

Pages: [1] 2 3 ... 30
1
After some careful tweaking, I finally nailed the look of the Nylon strap material and included the ribs that you would normally see. The final step will be refining the look of the striations and blend it into the height map before testing it in Unity


2
Good evening, guys (and gals). It has been a LOOOOOONG time since I've posted in this forum and today was a great opportunity to show off a new material that I've wanted to engineer for a very long time and finally found the courage to engineer it. It is based on the Nylon-Canvas Fibre found mainly on messenger bags and straps that require high strength. I wanted to 3d model it, but needed to step up my material authoring game as well...

This will be a microtexture (tileable texture) and I need to make sure it looks EXTREMELY good from a distance and up close on my characters. Below are some of my shots of the fabric and while I like it, I am trying to match the reference image, especially with the ribs. Not done with it yet...

Would love some feedback on how to further improve the detail and try to closely match the ribs on the reference image.

Reference Image (after a google search)



Substance Designer Renders






At the moment, it is looking like wicker... I need to make sure the "ribs" under the fibers are not showing too much...



3
Good to know. I am just using the map as reference while I paint... I can also use the normal map as a reference

4
Hey, guys... so I am using Substance Painter for the first time on a VFX character and I have ran into an issue involving the use of a Displacement Map that I baked out in ZBrush and it is a 32bit EXR and I set the mid level to 0. Now it renders in Modo just fine, but I am guessing, I will be forced to bake a height map in Substance Designer and bring it in Painter...

Has anyone successfully got a displacement map from ZBrush working in Painter?


5
What you see is the expected behavior at the moment.
In Substance Painter the gamma space is fixed, this means we consider the BaseColor channel to be sRGB and display it as such in the viewport, while user channels are Linear (like the Roughness and Metallic channels). So while the data between the two channels is identical, they are not displayed the same way.

Right now in Substance Painter you can't override the gamma space of the channels. You can try enabling the "color space" control in the Display Settings and leaving it empty. This will force the BaseColor channel to display as Linear as well.

So the final output should be fine... I'll export the textures and look at them in Substance Designer (it should look identical), otherwise I will have to just do my modified subdermal textures by using the base map and saturating that. Also, the RGB values are way different so that is throwing everything off.

6
Good evening, guys... it's been a while since I posted here, but after diving into Substance Painter last night to give a project a much-needed spit shine, I ran into an issue that involves creating user channels for texturing. I have authored a skin shader in Unity that uses Subsurface Scattering and I needed to make two textures for the shader (And Epidermis and Subdermis map) and I had to copy each parameter by hand to ensure the channels matched up (this needs to be a feature to copy data from one channel to another). Unfortunately, the difference in colour was very evident, especially when compared to the base colour. Both channels are set to sRGB

Epidermis Map (before desaturation)



Subdermal Map (Before Saturation)



And a video demonstrating this:

https://twitter.com/i/status/1067062230053806081

Hopefully, someone has run into this issue and has a solution because I will be also be using this in Modo... I could have taken this in Substance Designer, but I enjoyed the process.



7
I am having similar issues when I am baking and it crashes the entire program. I've already filed a bug report in regards to this crash and it is repeatable... I am baking out a normal map and the program just crashes without warning.

8
This is getting troublesome... I am doing a stream and it is freezing up. I just lowered the texture res a bit so I can have some speed back, and it just stopped working.

9
Same problem.

So I just noticed if I have both texture sizes set to the same as in the gif mine works. http://i.imgur.com/kDlEikH.gifv

Thanks for the work around. This could have been a big blocker!

Nope... back to our regularly scheduled program :)

10
So I just noticed if I have both texture sizes set to the same as in the gif mine works. http://i.imgur.com/kDlEikH.gifv

About to try this now.

CONFIRMED!! I did a new bake at 4K and everything works as expected.

11
Just ran into this issue while doing a painting demo... had to save my work and try it on a lower setting. For now, I will just paint the details manually.

12
Hey guys, sorry to necropost, but will this set up work in Modo 10? I have finally upgraded and now want to test out Substance Painter for use with Modo and VRay... Thanks

13
Substance PainterSubstance Painter - Discussions - Re: HDRI Import Issue
 on: July 11, 2016, 01:09:17 pm 
Is your HDR in a power of 2? Such as 4096x2048... this usually happens when you try to import an environment map that is not in the power of 2

14
I will have to look at that again... though I did check the texel range of the wood beam, which is 6x6x8... I think I have seamless turned on in the atlasmaker and that is making the wood look big... I will check the texture.

EDIT: After checking my graph, the material scale is at 1. I think setting the wood material to seamless might help this issue

15
After some fiddling with the pixel processor and altering my substance a bit, I got the wood planks looking very random and natural as well... and I also made it so that this randomisation only occurs when the planks are enabled... it was easier than I thought. And I think I am going to add some knots and ensure the same behaviour occurs with that pixel processor as well...

Pages: [1] 2 3 ... 30