Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - ptn

Pages: [1] 2
1
Hi all,

I'm trying to use the script from the Substance python pages to update the windows registry to add a custom library path. It works for half my team, but not the other half. When I looked into why, it turns out that in the fail cases those users did not have a HKEY_CURRENT_USER\\SOFTWARE\\Adobe\\Substance Painter\\Shelf    or    \\Shelf\\pathinfos folder.

Does anyone know why this would be? I thought the winreg Shelf entry was a default for the software to operate but it seems not. I'm polling the team, but so far we all seem to be on the same version (2021 7.1.1) and all have installed via the Adobe CC app.

Anyone seen this before or have any guidance on how best to continue to debug? I feel a half step from simply uninstalling / reinstalling as a test but that's basically a blind fire.

any insights appreciated. :)
Pete

2
Looks like the python path isn't viable but investigating whether the project template (spt) will capture what I need.

3
Hi all,

I'm curious if we can access and set various post process effects via python. Ideally I'd like to be able to set a viewport look to be consistent across multiple artists (all the same buttons ticked and values set) to help ensure a consistent look. I don't see those via the python API atm. I also don't see any documentation on the Yebis site about any python API there.

Is there any other pref file that I can access? Even the registry editor with the various library paths doesn't seem to have anything that I recognize as these settings.

Is this anything we can do, or is the idea a non-starter?

Many thanks!

4
Hey all,

I can generate an HDR texture in substance and save it out as an HDR. When I import to UE4 manually, it is interpreted to a texture cube, which is what I want. However, when I try to use the same graph in the engine "live" the output texture is always read as a "texture". I've tried a number of "output" settings and types but nothing seems to make a difference.

Is there a way to have the output of the substance plug-in in UE4 generate a texture cube and not as a regular texture?

thanks in advance for any help!

6
Awesome. Thanks for the tip. Now that you mention it, I think I set something similar up ages ago for ZBrush quick save/cache files and forgot about it. I'll give this a shot. Much appreciated!

7
Hey all,

I'm looking to allow Substance Painter to use more of the alphas and hdri env maps I have on disk.

It seems that the only option for including them into SP is to Import them which effectively duplicates the file into the user shelf area. I have not been successful in getting a shelf to recognize the files available (elsewhere on disk; not within the shelf dir structure) through a single folder shortcut placed in the appropriate shelf area.

This could mean a lot of disk space eaten up duplicating things that ideally would only live on disk in one place.

Sub-shelfs don't seem to be the answer.

Am I missing something? Should there be an option to work as I describe? Or is this the expected and normal behavior? Just fishing for insights and couldn't find anything directly on this in the forums.

Thanks in advance!
Pete

8
Sorry for the delay.

https://youtu.be/6oJrot26ebI?t=8m48s

This is the video and the bit I was mentioning.

Perhaps I misunderstood. It sounds like ONLY diffuse / base color will get a custom profile? And Normal maps and any masked or single channel layers will not?

Hopefully you won't read this for couple days. Happy holidays! :)

9
Yup. I've confirmed that Pshop isn't doing any adjustments. And understood it's in linear space.

Should the Normal map be showing up with a custom Color Profile? Maybe I misunderstood the video...

10
Hey all,

I've exporting a test asset from Painter to Photoshop via the exporter button. Having watched the Youtube video, my expectation was that the normal map file should have a custom color profile assigned. That is not the case. It is marked as "not managed". I have confirmed my color settings are to preserve all embedded color profiles. In fact, the diffuse doc shows up correctly with custom color management.

Is the expectation different for the normal map versus the diffuse map?
Has the expected workflow changed since the video?
Is there a profile I can select from the pop up list in Photoshop to align with Painter?
Is there something I need to configure to make sure the custom profile is assigned as planned?

I expect this to be user error since I'm just starting to mess around with this but thought I would ask for some guidance on what to check.  :D

Photoshop CC 2017.0.0
Painter 2.4.1





11
Tried a fresh install and the 'run as administrator' option. Same hang at the same point as before.

Still no joy. :(

Hopefully a fix (for whatever is going on) in next release. I'm back on the old version for now.

12
Oh yeah, Duh. I'll give that a shot. Ha. :)
Thanks!

13
I moved back one release version and seem to be able to get the app up and running again.

0.5.0.319 seems to work for me but 0.5.0.333 continues to hang/freeze at start up. The "It's beta software" window still pops up but is unclickable.

Pete

14
I have a licensed version of Substance Painter. On version 05.0333 I seem to get a hang and implicit crash while it has the "check for new version dialogue" up. It had been working fine on the windows PC (win8) earlier today.

I had initially purchased the app through Steam. Was frustrated about the steam check-in process so uninstalled  from steam and re-installed it via Allegorithmic site. All fine.

Installed local license. No probs.

Started to import local HDRs for custom lookdev ens adn linked local dir of B+W bit maps for alphas in shelf dir in "My Docs" area.

Then hangs stared happening repeatedly. Pop up window states "(not Responding)". Main app window has "checking for new version..." in lower right corner with red box.

Regressed all changes (removed lookdev exrs, license file, alpha shortcut, fresh install). Still hangs. Haven't gone back to steam install yet.

Not sure what to try next?

Pete

15
OK, looking through the GPU note on the product page FAQ it looks like the GPU in this laptop is too old, and not the 5XX required. Sounds like problem explained.

Thanks!

Pages: [1] 2