Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - wolfen

Pages: [1] 2
3
Are you not editing the material settings in the render window show depth? Primarily enabling tessellation.


4
So the 3D View save state doesn't seem to save... everything. I have to always go into the material and re-enable the Tesselation. It's driving me mad. It's storing my rotation / position of camera but nothing else. Environment is gone, shader settings gone. All of it reset.

Designer 2019.1.2

5
Weill if I recall it only needs to be inspired by the image. Not an exact replica. I'd say you are on the right path. That one inspired the grills on mine actually. I doubt Ill win this thing but it's good for practice and learning hehe.

6
My entry for the Materialize Contest. (WIP)



Reference:



https://www.artstation.com/artwork/Qq2W4

Also my apologies to you Kay.

That image is AMAZING. I was actually very curious how you got that kind of blue lighting kind of coming out of it.

7
@wolfen please create your own thread to avoid confusion: I am going to delete your post.
Yeah, sorry about that. I thought at first it was an everyone kind of thread. My bad. =)

8
Hello, hope someone can help point me in the correct direction on this. Here is the setup.

I am using a tile sampler to input 6 different patterns. Each pattern is a different angle of a 6 sided shape. The reason I need to do this is the shape has a slope in it, and I want to make it so that you can input a mask that arranges the shapes to follow that pattern. But the slopes need to line up their angles to make that shape.

From a side view the shape is like this __/¯¯

So I need those elevated shapes to line up properly to make the shape.

A link to the 3d view this far https://i.imgur.com/Ux2yFJl.png since I think that might help explain it. So if i wanted a triangle shape I would hope that a black and white image could arrange these the proper way to create the triangle shape. Where pattern 1 might be a slope up / and pattern 2 might be the slope down \ and pattern 3 might be the __ lower part.

Boy I hope that makes sense. Anyhow, I have tried using the pattern distribution on the tile sampler but that obviously doesn't work so simply because the ranges will force the wrong pattern on all sides.

Any ideas? Because I don't think the pattern input on the tile sampler is going to achieve this in a simple way.

9
Hi,

I was wondering how the pattern distribution map works because I can't seem to nail down how to use it with more than 3 patterns. What I am trying to achieve is having the arrangement of the 3 patterns based on the distribution map but it seems to entirely ignore one of the patterns. This is using either gradient based pattern in the pattern mask or a solid color. I would have assumed something with some fall off like a gradient would place Pattern 1 at white, pattern 2 around gray, and pattern 3 around black or something to that extent.

Any pointers or videos that might help me understand this better on this node?

Thanks!

10
Quote
I don't recall having this issue in the previous build of SD. I upgraded to the new 2017.2.1 version and started seeing this problem
This is not an issue specific to SD. The fact that you started noticing it just after having upgraded is probably just a coincidence.

Quote
Should I be setting the whole substance as a 16b? Or just the nodes where this is happening at?
Setting the whole substance as 16bpc would probably solve the problem but would be overkill. Conversely, just changing the nodes where you start noticing the banding may not be enough to solve the problem. In all likelihood, you need to set to 16bpc all the nodes leading to the one for which you notice banding (and if that includes a bitmap you imported, you need to make sure it was imported from a 16bpc file, and that it was created using a 16bpc process).

Quote
But again.. it's really odd that it just goes from smooth to banding like that.
The stepping is already there in the image before your normal map node. It's just that we don't see it. Our eyes are not very good at distinguishing low dynamic range colors. Usually, 8bpc is sufficient to encode colors/luminance so that we don't see any stepping (once gamma is properly applied). However, we start noticing it instantly when filters based on computing the local slope are applied (like computing the normal map). Also, when using the image as an height map, you would notice the stepping.
Reconstructing a smoother normal map from an 8bpc height field is possible, but it would be slower, not guaranteed to be perfect, and would miss high frequency normal details (it would blur the result).

Ok. That makes a lot of sense. Thanks so much for the info. I already started trying this on a graph I started and it seems to be doing the trick. Stepping back a node or two and changing it to absolute and setting the Bpc I mean.

=)

11
Substance DesignerSubstance Designer - Feature Requests - Re: Two requests.
 on: October 26, 2017, 02:45:52 am 
Hey sorry I didn't see this reply for so long haha. Just wanted to say thanks for the tips. =)

12
For height and normals, yes it is usually better to work in 16bpc. If the intended result is noisy / has a lot of high frequency detail to hide the quantization, exporting in 8bpc may be sufficient, but with smooth surfaces, either exporting at 16bpc or using dithering is required.

See this discussion on Polycount for more in-depth info about this: http://polycount.com/discussion/148303/of-bit-depths-banding-and-normal-maps

Hi Cyrille and thanks for the reply.

So I just want to make sure this is clear. So what I am seeing is in the atached image. The levels aren't actually set to change anything right now and you can see in the 2d view its smooth as butter. But if you look at the height to normal node you can see it's doing the banding already.

I don't recall having this issue in the previous build of SD. I upgraded to the new 2017.2.1 version and started seeing this problem.

Should I be setting the whole substance as a 16b? Or just the nodes where this is happening at? But again.. it's really odd that it just goes from smooth to banding like that. It also happens on the Ambient Occlusion node.

https://i.imgur.com/zaJX6Ir.png
https://i.imgur.com/JLHyFHr.png

13
I have an unusual situation. My 2d images through out the graph are showing no banding but when I get out to some of my outputs I am starting to see banding (step effect) on the height and normals. If I set the absolute value of the document from 8bit to 16bit this resolves it. But I just find it odd that it doesn't show up at all until the end of the graph really. Is there something I am missing? Should I pretty much always work in 16bit?

14
So I was doing some warps and slope blurs and realized my image was no longer seamless. Any suggestion on how to make the images seamless again?

Pages: [1] 2