Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - animatexyz

Pages: [1]
1
I have a large project coming up where we'll be exporting GLTF models that have multiple variations in texture and color. I'm trying to make all of the variants in one project for a given object. One of the processes that has been slowing me down during our R&D phase is having to rename the texture sets for the different variants prior to exporting. For example, I need to render out one version in black and another version in red. The GLTF exporter automatically names the GLTF file whatever the project name is and the texture sets get whatever they are named in the list. I have to rename the set list once for the black version and once more for the red version. This isn't so bad when you have only two variants. But I have about 90 objects that have 3-4 variants per object. A lot of times we have to rerender these after we view them in our software and see that things aren't looking quite right in one area or another, so the amount of times I have to rename the set list becomes a massive waste of time.

Right now we're considering just making separate project files for every variant but I don't think this will speed anything up. I think it will end up being slower. So I wanted to reach out to the community here and see if anyone has any advice for a better workflow or maybe drop some Substance knowledge that I've missed.

Thanks

2
I think I've figured this out on my own. I wasn't baking any maps. I recalled a tutorial mentioning that in Painter you have to bake out maps for your object. Once I did this and then exported my textures and a .glb everything was perfect.

I was assuming that wouldn't be necessary for simple single color objects that are smooth. However, when I would export my textures without pre-baking I was getting the combined rough/metal/occlusion map as a solid blue map rather than a solid pink map. Basically I was getting the inverse of what I needed.

3
I'm getting mixed results depending on the exporter that I use as well as the viewer that I use. So far Adobe Dimension has the only exporter that gives me the same expected results in both GLTF/GLB viewers. The viewers I'm using for testing are the Don McCurdy three.js viewer https://gltf-viewer.donmccurdy.com/ and the Babylon.js viewer https://sandbox.babylonjs.com/. I'm using the glb format.

When I export from SP I get inaccurate results that look as if the environments aren't lighting the object. However, in babylon.js, if I turn off the ambient light I get the correct results. I don't have to do this with the export from Adobe Dimension. It just works right on import.

Something else you'll see is that the Ray Ban logo on the model shows up better in the SP with babylon.js combo when the ambient light is off. As well as the SP with Three.js combo. In the others you'll see that the logo is barely visible.

I've also tried several other methods of export such as Blender, command line tool from FaceBook and various Maya plugins. So far Adobe dimension seems to work the best but it's not without it's quirks either.

I'm hoping someone reading this will have some input as to why I'm getting such crazy results and possibly some answers on how to fix things, better workflows and where I'm screwing things up.

Thanks


4
Sorry for not replying. We did end up resolving this. It ended up being the resolution settings. We were set at 512 which was working fine for solid colored objects which was necessary for our purposes. We pushed to 1024 and that cleared things up but we had to use it sparingly with only the most necessary textures since we're running everything in real time.

5
Thanks! This is the method I was trying previously but I haven't seen this tutorial on the technique. I'll try it out and post the results.

6
Is there a way to stamp a pattern around a shape and have it point in the same direction as it follows the curvature of that shape? I'd like to do this procedurally rather than with bitmaps in photoshop. I've tried using the tile sampler. I can get the pattern to go around the shape but it doesn't continue to follow in the same direction and it only looks good on one side of the bezel.




7
I'm getting some color banding in iOS with our pbr textures. We're layering uniform colors and using a blur node to blend them together to create a layered eye shadow effect on an eyelid object.  In Unity everything looks great. Once we build the app and view it on an ios device the colors are banding and the gradation from blurring isn't working.

Do we need to set the color nodes to a certain bit depth or range between 0 and 255?

Is there a setting in xcode that we need to change?

8
Update: We've fixed the issue. The problem was in some of our blend nodes where we were using the switch blend mode with a function to swap the opacity, (float value) from 0 to 1 to add/remove noise. This was being switched on and off with a boolean in the input parameters. We had no issues with Unity's compiler being able to convert this float to a boolean but apparently the xcode compiler is not capable of handling this.

9
We're getting some odd behavior from the base color output in a couple of our sbsar files. In Unity we have two models with two different materials that were built in substance and they look as expected. We're texturing our models using the metal/rough workflow in Substance Designer. When we load the build onto any ios device, the base color/albedo is getting misaligned. I ran a test by adding a UV snapshot into a blend node and setting that to switch with a function so we could toggle back and forth from the UV texture to the procedural color. The UV's are properly aligned. All of the other PBR attributes look as they should. All of the procedural textures I've added through the roughness and metallic outputs are aligned. The normal and occlusion maps are aligned. The only thing getting misaligned is the color which UV snapshot is being fed through.

We've found a few posts in other forums that say we may need to export color maps to fix the alignment issue which makes sense since our UV snapshot is aligned properly but this defeats the purpose of it being procedural which we need for our end user. We though this might be an issue going from OpenGL in Unity to Metal in iOS but we swapped from Metal to OpenGL in the iOS build and ended up with the same results.

Any ideas?

10
https://tutorials.allegorithmic.com/courses/c0cfec6d04eb6ee8768207b270d435fd

I'm going through Qu Bin's brief explanation on how he created the weave fabric and I'm already hung up from the start. In the first graph image he changes the shape of what I believe is a bell shape node. He starts with the shape node and then uses a curve to shape it to a rounded square. I can't for the life of me get the curve to reproduce this shape. Everything I try still results in a round shape.

Any ideas guys?

Pages: [1]