Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Smoluck

Pages: 1 2 3 [4]
46
Hello.

I'm experiencing some issue displaying the same Rendering as SB Painter in Modo. I'm looked into some forum thread like those from Wes McDermott here and some on modology.fr Modo French User Forum, but didn't found how figured out the same render in both software. So here i'm trying to find a workaround to this challenge. I'm probaly doing it in a wrong way but that is a good way to get involved with tools. So feel free to comment ^^
 
Setup both Software to Match the same result of Sub Painter viewport and Modo Render.
I'm runing Modo 901 SP3 with the last 2.1 Subtance Plugin. My scene properties have been set to Linear color mode for every settings (Select the Main Scene Layer): Default 8-bit ColorSpace / Default 16-bit ColorSpace / Default Float ColorSpace ---> All to "Linear" mode


Also I've disable the "Perform Color Correction on OpenGL Objects" in Preference ---> Display ---> OpenGL ---> Performance.


Goal. Having no problem with the CIO (Color Input-Output Management) that still don't work well between Viewport and Render when mixing Linear colorspace files (like all the Grey maps like Spec/Rough/Metalic) and sRGB Colorspace files (like DiffuseColor/SpecColor).
I've made that in order to load Roughness and Diffuse map directly as linear setup. and see them properly in terms of Colorspace in the Modo 3D Viewport as well as the one in SubPainter when you activate the color key to see the different maps.

Here are the result showing in both application viewport.

(For convenience and in order to didn't affect my color check. I've change the Background Color in Substance Painter to the same as in Modo on both color as it works as a gradient to RGB 0.36 0.4 0.45. PS: That's not a Copy / Paste screenshot of the Modo viewport pasted over SPainter :-D )





So Diffuse / SpecAmount(Metalic) and Roughness looks OK. But Normal are good too.
But when i'm looking to the Preview render i got a darker render (Talking about the FinalColorRender), even if i turn it to from sRGB to Linear mode. (It should be set as Linear mode, right ?)
The DiffuseColor / Roughness pass are ok tooked on side. but the Environment / Lighting  looks a lot darker. How I can be sure to get the same result in both Modo and Sub Painter ?


Sub Painter on Left / Preview Render in Modo on Right




Conclusion and Workaround:

In order to fix that a bit, I've turned the Preview Render from Linear to sRGB Colorspace in order to get back the correct Gamma value for the Environement Background image and Lighting that come through. And also setup a Gamma value of 1/2.2 (=0.4546) to all my input texture maps.

Now i'm close to the twice software, but there is still issue on the Metalic pass.




Quote
Usually i was working on a different ColorSpace setup:

"Perform Color Correction on OpenGL Objects" enable.

Default 8-bit ColorSpace / Default 16-bit ColorSpace to sRGB

Default Float ColorSpace to Linear.

Using this setup was painful because in the viewport even if the Diffuse map was OK , the Roughness was displayed wrong in term of Colorspace.




47
Link Broken...

i'll take a look to TF website.
the file on their website is from Aug 5, 2015, Subplugin v 2.1.0.

do there is some newer file as 901 SP3 just came out ?

48
Hello, I've used a long time ago the little tool from Luxology Imagesynth & and 2, and now, as i'm going deeper on SD, i've tried to reproduce the Chunk system of ImageSynthesis, in order to use multiple area on few photos and mix them together to create Fully tileable texture.

some exemple about the concept:
http://www.youtube.com/watch?v=1b0JOokyGwk
http://www.youtube.com/watch?v=Z4adpHeQIlU

But at first, i can't find a way to use the wall photo resolution, so i loss a lot of the details in it cause SD stratch them from 3008*2000 pix to 4096*2048.

On a second point the "make it tile patch" node couldn't handle multiple chunks at the same time.

49
I agree with you unity2K, as i got the same problem with my large library of texture.

50
I've also the same problem, i'm not sure that the release on Steam is the right one, i want (SD4) cause the discount on Steam ends on the 4th December and SD4 will be released on your website at the same date (sounds weird).
Also i didn't wont to be rules by the internet connection through Steam to use SD4, if i pay for it.

PS: I want to figure out that i couldn't change my user name under Profile --> Account Settings. it look's locked to the first part of my email adress, even if i use my password to modify this information (is that related to the "%" in the password).

Pages: 1 2 3 [4]