Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - burning01

Pages: [1] 2
1
and for quick referance here is a before and after

2
So I managed to find a work around... (sbs attached below)  hope this helps someone

This sbs creates a custom gradient from shapes, to give more control than a standard gradient (and levels adjustment) gives over the spread of the gradient, also it improves the colour blending by using a sRGB conversion node, which gives a result similar to that of working with 32bit colour gradients.

ie. no black lines :) or weird bluring

I did attempt to change all nodes to 32bit to see if that solved the issue it didn't - I don't think designer knows how to deal with 32bit colour out of the box (I mean other than displaying a 32bit colour image- any processing is probably done in 16bit or below- which isnt an issue as long as there is a way to convert it into 32bit properly once its processed)

Anyway I'm still not happy with the smoothness of the created gradient so Im going to be working on that as well as finding a more accurate way to blend colours that is more akin to 32bit colours.

3
I think I have narrowed it down a bit...It seems that one reason for those line artifacts was downscaling (the mask was set to 2048 while the blend node was set to 512)

However...
I am still getting the issue regardless; just now its something the actual blur node is doing to the image. with intensity set to 0 there are no line artifacts as soon as I put anything greater than 0 those dark line artifacts appear.

I guess I need to see if I can open it up and change something inside?!

4
Why the 2D output doesnt have the lines before the blur and only the 3D viewport does - Then after blur they both have the lines seems a bit weird too?!

5
This last one shows what happens when blur is applied ( both 3D view and 2D output have dark lines)

6
This shows the same again but the 3D view is zoomed in so you can see the dark lines better

7
dark lines with no blur (only showing in 3D view, the 2D output node has no dark lines)

8
just showing the example graph

9
I have attached an sbs file with a simple example to this post so you can have a look at the issue for yourself.

The problem I am having is that when using shapes or svg as a mask - I am getting these dark lines appearing at the edges, they may seem like something that's not real important but as soon as I put a HQ blur node on the shape those small lines turn into big dark lines and I need a smooth transition without any dark lines.

I basically want to get a nice smooth colour gradient without the black lines. I'm not using an actual gradient as a mask because even with levels it does not give me enough control over the gradient, so this is the way I've come up with to solve that issue but it wont work if I can get rid of those dark lines.

I have also included some images for quick reference...

10
Substance DesignerSubstance Designer - Technical Support - SOLVED
 on: April 30, 2018, 03:49:48 pm 
I managed to come up with a way to get it done a few weeks back and just didn't have any time to make a post about it.

So for anyone else who might need the same functionality...

I did manage to get it working using presets but it was very unstable, sometimes it worked and sometimes it didn't, so I eventually scraped that method because I need it to work properly everytime and not cause any further issues seeing as in my actual work I need to be baking out 100's of maps at once.

The method I found that was most reliable was to create a secondary graph for outputting maps and instance the material graph in that secondary graph with the exposed parameters on each material instance set independently of each other to allow the outputting of several variations from a single material without having to tweak settings everytime. (essential a method of making presets without using the inbuilt preset function that for me didn't work very well)

So feel free to download the attached _Preset_Test_Solved.sbs which is a small sample substance file which you can see the method I describe in action- which should clear up any misunderstandings.

11
So this graph has presets which change the colour of the foreground and currently outputs the Current colour to all 3 output nodes - What I actually want to do is output a different colour preset to each output node, so then I would get 3 different colour maps (in this case red, green and blue respectively).

Like I say this is a simple example to illustrate the issue I have. My actual use for it; I am wanting to set it up to output a hundred or so variations (not just colour)

12
Hi, I'm wanting to save a bunch of presets of the graph state (or part of the graph state) and then send those different preset states to different output nodes. Im not sure how to go about achieving this result and help would be great.

I have made a simple example of what im trying to achieve
Attached as an .sbs file for you to have a look at
as well as a screenshot for quick reference.

13
Green shows what part of the screen allows drop down menu to be placed sensibly on the 1st monitor and the Red shows the area that activates the drop down menu in an awkward position on the 2nd monitor.

14
Showing the bottom of screen putting the drop down menu in the right place

15
Showing the top half of screen putting the drop down menu in the right place

Pages: [1] 2