Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Salad

Pages: [1]
1
Hi, posting here in case anyone else runs into this situation:
Unfortunately I didn't keep track of my annual subscription & did not realize it would auto-renew. I purchased the subscription last year following the suggestion to do so before October 30, 2020 to lead into the perpetual license purchase + final year of maintenance offered until November 1, 2021.

According to the FAQs and information earlier in the year, we have to go through support in order to purchase our final perpetuals + maintenance from the 2019-2020 subscription as it's deprecated on the site.

Has this changed?

If it is done through the site, I am unable to do so as my subscription has expired today. I've sent emails to contact@substance3d.com.

Would like to confirm in this thread what the correct path forward is.

I very much wish to keep things done through Substance3D and keep Steam out of it.


EDIT: Can confirm support set me up with my maintenance. There was an issue with my subscription that was resolved, thank you very much!

2
Just want to update the situation after testing Substance Painter 2019.3.1. Can confirm it is now working on the Lenovo Yoga 730 with Lenovo Active Pen 2 which is using Wacom AES technology! Curiously the Windows Ink issue with "stuck" sliders doesn't seem to be happening with this setup. Sadly the update has made the experience worse on the Huion Kamvas Pro 13, laggy sliders plus the lack of touchbar scroll usage makes it difficult to enjoy the updated brush system.

I hope the issues with Windows Ink can be fixed on the substance side since it seems to be affecting a lot of tablet users, including on the high end wacoms. But on the bright side it is really exciting being able to use the stylus on a 2-in-1 laptop in Substance! Feels like magic  ;D

3
Would you please tell me if there is any progress on this issue? Thanks
As far as I can see, this has been the only response for the issue since then:
https://forum.substance3d.com/index.php?topic=28859.new#msg118646

Hoping for the best with you, would be awesome seeing it working on the P52!

4
I just wanted to chime in to let you know that we monitor this kind of thread. While we don't have news to share on that subject for now, we keep it in mind. We plan on reworking a bit how we handle Tablet Graphic in future versions. While we focus on Wacom hardware, other kind of pens/tablets should benefit from it as well.

I don't have a precise ETA to share at the moment.

Thanks for the reply! A rework sounds promising, but I do want to correct one important thing:
https://forum.substance3d.com/index.php?topic=28834.0
https://forum.substance3d.com/index.php?topic=26131.0
All the users talking in this thread as well in previous threads here are talking about the same technology: Wacom AES pens for Lenovo and Dell laptops, so it is Wacom technology having the issue.

In fact, I have had no issues working with both my Huion 610 Pro V1 drawing tablet or my Huion Kamvas Pro 13 display tablet in Substance on my desktop at all. Right now the only way I would be able to use Painter on my 2-in-1 laptop is if I were to attach one of the Huions.  :'( I have also read that people use Substance Painter a bit with the Surface Pro which is also not Wacom tech.

Jeremie Noguer responded in monitorhero's thread about working with Wacom on this issue in May. As Substance is subscription based I hope the update comes sooner than later. There was a bit of side discussion on how Wacom pen technology for laptops are buggy in ZBrush in this thread, but it's still worked in every program I've seen except in Substance Painter. It's honestly a shame that it seems it's never worked for Wacom AES technology since it seems amazing being able to work with Painter on a laptop directly, but with alternatives to Wacom becoming more popular, it sounds like it will be a good idea to rework pen support to encompass more.

5
Hi, I've tested some changes and have some additional information.
In my initial post I was using the Wacom Feel Drivers for my Lenovo Active Pen 2 (Yoga 730 15 inch):
http://us.wacom.com/en/feeldriver/

I was unable to have any viewpoint interaction with the pen aside from one stroke on the 2d view I was unable to reproduce  (with some severe lag before the 3d viewport updated).

I've tried replacing the Wacom driver with the one from Lenovo's site, the Active Pen Driver for Windows 10 (64-bit) - Yoga 730-13IWL, Yoga 730-15IWL: https://download.lenovo.com/consumer/mobiles/maye01af.exe

Now I have the same behavior as monitorhero. It seems to act like a continous mouse click that isn't stopped unless you overwrite the input with the touchpad or a mouse & functions similar for drag and other navigation.

@monitorhero As for the Blender/ZBrush, I think I have the same issue in both - it doesn't seem as noticeable in quick drags but it seems like it's difficult to have subtle Move brush use. My guess is that holding the pen down is registering as the hold=right click  command. You can try swapping the Lenovo Pen driver for the Wacom Feel one and see if it makes a difference for you. The customization app for both drivers kept my settings and seem identical with a slight layout tweak(including the lack of mouse click buttons, WTF?), but it seems they're not identical as there's different behavior in Substance Painter.

6
Hi, started using a Lenovo Yoga 730 15 inch laptop recently with the Lenovo Active Pen 2. Have tested the pen & drivers in Blender, ZBrush, Clip Studio Paint, and Windows apps & can confirm it is working.

However, the pen appears to have no functionality in Substance Painter in the viewport.  I can see the brush cursor move around on the model but I can't use the pen to navigate or  paint in both 3d and 2d viewports.

I can use the pen to switch tools & materials but no functionality past that.

Did manage to somehow do one registered stroke with the pen on 2d somehow, but  it was laggy & unable to be reproduced.

Have tested on both  2018.3.3 as well as  the new  2019.1  version.

The symptoms seem very similar to this thread:  https://forum.allegorithmic.com/index.php/topic,26131.msg104867/highlight,active+pen.html#msg104867

I've attached the log file, thank you for your time.

Pages: [1]