Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - JabbaTheNut

Pages: 1 2 [3]
31
When I do a UDIM bake with a low and high poly, but without a cage, all is fine.  However, when I do the same UDIM bake with a cage (e.g., the low poly pushed out a bit), the bake does not respect the UDIMs. The caged UDIM bake does all bakes in 0-1 UV space as though there were no UDIMs. Each bake multiplies on top of the previous bakes.  Is this a known bug?

32
Out of curiosity, how would you paint (i.e., color) these stitches?

Alternatively, how would you create a stitch mask from the height map that would isolate just the stitches?

One thought would be to export the height map to Photoshop and adjust the levels such that anything that was 50% gray or darker would be black and anything lighter than 50% gray would be white.  Is there an easier way?

33
Substance PainterSubstance Painter - Discussions - Re: AO Problem
 on: March 11, 2017, 09:52:22 pm 
Please disregard.

While I don't understand it yet, the problem is related to the cage.  In the problematic bake, I did not use a cage.  When I use a cage the occlusion looks fine.

I wonder why the absence of a cage would produce edge occlusion and not full occlusion? Just curious.

34
Substance PainterSubstance Painter - Discussions - AO Problem
 on: March 11, 2017, 08:33:38 pm 
I am curious why the Substance Painter's (SP) ambient occlusion bakes are so different from other apps.  In the attached images, you will see AO bakes of a waist belt model in SP and in another application.  The results from the other application match those I have also gotten from Modo, Maya, MightyBake and HandPlane.

Note that the AO in SP only captures the edges.  Totally occluded areas are not represented.  For example, there is a belt strap in the middle of the waist belt.  The surface behind the belt strap is not occluded.  Why?

You can see the effect in the belt.png image.  Look at the belt loop on the left side of the image.  The surface behind the belt loop is light, not dark.  It is weird looking.

35
D,

That was definitely the problem!  Thank you for your help. I also appreciate the Input Color Space Rules tip.  I am now using that one, too.

36
I am trying to bake a simple normal map for a pair of pants.  The normal map is for the seams of the pants.  In the attached images, you will see the UVs for the pants, the results of the SP bake in SP and the results of the SP bake in Maya 2017.

The normal map bake in SP looks very good in SP.  There do not appear to be any problems.

When I bring the SP baked normal map into Maya, however, everything goes wonky.  I have tried DirectX and OpenGL, triangulating the mesh before baking.  Flipping the Green channel and then the Green and Red channels.  I am at my wits end.

Can someone give me some guidance on what I may be doing wrong?

Here are my UVs:


Here are the results of the SP bake in SP (looks good):


Here are the results of the SP bake in Maya 2017 (looks wonky):

Pages: 1 2 [3]