Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Zer0Sum

Pages: [1]
1
Is this not possible, or am I just missing a setting?

I have a model surrounded by a 3D background. This works fine in the main painting/editing window, but when I switch to the rendering view, I can only see the outside of the model, there is no backface culling.

This makes it useless for rendering.

The only option I have is break the background in half, export both halves, and then turn on and off each half depending on which side I am rendering the model from.

Is this the only way of doing this, or am I missing something?

This is the scene from within the main window:
https://imgur.com/1G3deaX

And the same scene from the render window:
https://imgur.com/6VjQgXE

I am using Substance Painter version 2019.3.3.

Thanks for any advice!

2
Hello,

I am doing some experiments to try to find the best way of texturing a large assets in substance painter, and get it into unity. The easiest way is obviously to just split up the mesh into multiple pieces, and texture each one individually, but when I did this I noticed seaming and gaps that were hard to get rid of.

So, I am trying UDIM.

So far, it seems to be going well. I can export from 3DSmax (using unwrella for the unwrapping) into substance painter, I select the UDIM option, and I get all of my texture sets in a different layer. So far, so good.

I now texture everything, (I am just using very simple concept textures here!) and I get this:

https://i.imgur.com/Ljnk11xm.png

Looks fine, the uvs line up between the different texture sets, there are minor seams, but nothing too serious. So I export to unity.

Unity picks up the multi-sub object, and creates a mesh renderer with 8 slots. So I create my materials and set them up with albedo, metallic, etc, but I notice this issue:

https://i.imgur.com/88wOqJJ.png

It seems that there is heavy texture distortion on all of the textures. I can't seem to find a reason for this. I am guessing that it is something to do with the UV's not being picked up?

Can anyone shed any light on this? Based on my research on this forum, it seems that UDIM with unity should work, is this not correct?

3
With the release of SP 2018.2 and nVidia 398.82, I was just wondering what the status of the current driver issue is, as mentioned here:

https://forum.allegorithmic.com/index.php/topic,22711.0.html

I have decided to continue using the latest nVidia drivers, since I need up to date drivers for other programs, and instead I am using Substance Painter 2018.1.1, since this seems to be reasonably stable.

If I upgrade to 2018.2, is it still recommended that I downgrade my graphics drivers, or has this issue been resolved either in Substance Painter or the latest nVidia driver release?

Thanks!

4

First of all, I have seen the post about the latest nVidia drivers causes crashes, and I have reverted to 388.71. This has actually made the issues worse.

Substance painter has always run fine on my machine. I have a 980ti with 32 Gb's Ram, which should be plenty.

I have recently updated to 2018.1.3, and I initially noticed a frequent freeze when changing layers. I downgraded my drivers to 388.71 as per the post on the forum.

However, I am now still getting frequent crashes, usually when changing layers or adding a new material from the library, but it can happen almost any time.
Sometimes, my entire screen goes black, which seems to indicate a display driver problem. I see notifications in windows that the "display driver failed to start".

I did have the TDR popup appearing, which I ignored until now, since it wasn't causing any issues. I have now modified the registry to solve this issue, but it hasn't made any difference. I have also increased the size of my swap file, again, no difference.

I'm assuming at this point that it's an issue with Substance Painter 2018.1.3.

The substance painter log (attached) shows my driver version as 391, but I definitely did downgrade, substance painter even complains about my drivers being "outdated".

I also attached my Dxdiag log.



5
Hi,

I am looking for some advice on the correct workflow for a complex object I am creating.

I'm working with 3DS max and substance painter 2.

I am creating a model of a spaceship, which requires both a visible exterior and interior (It's for a game).

This has presented a challenge. Unwrapping and texturing the entire ship as a single object is not really possible due to the complexity, so I decided to model the ship in several pieces, with each interior room being once piece.

This worked well, but I am now having a problem aligning the textures between these different objects.

This image should show what I mean:



Here, the upper texture is one object, and there are several rooms below this, which are individual objects, once of which has a texture on it.

What I want to do is match up the texture from the upper object to the lower object, without leaving a seam, while still being able to unwrap the interior as a separate object. I would also like to be able to eliminate seams around the windows, etc.

My knowledge of unwrapping and texturing is not extensive, so this may be simpler than I am making it, but I would appreciate any advice than I could get.

Pages: [1]