Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - patrick_14

Pages: [1]
1
I asked this on Discord too but does anyone know if its possible to run multiple versions of Substance Painter? 

So a co-worker is working on Project A using the most recent version of Substance.
I'm on Project B and C and using a much older version ( I've learned the hard way never to upgrade in the middle of a project, let alone two ).

However I need to temporarily help out my co-worker and work on some of his files.  I can't .. without updating my copy of Substance, which, or so I've been told before, is not undoable.

Is that correct or is there any work around for this?

Cheers,

Pat

2
Solved .. reassign texture sets rebuilds the layers.  I think very simplified workflow and asset creation is the reason I've never seen this happen before. We only have one texture set and its always called the same name for consistency. We now have a few freelancers using Max which seems to of changed things without them realising.



So, my usual workflow is that I'll work on a project to completion.
Then, when I've a new project thats for the same engine, requires many of the same base materials etc. etc.  I'll use the Edit/Project Configuration panel to swap in a new model. Once I have new resource textures I'm good to go. I've the same shader setup, the same display settings, the same materials, the same color masks assigning the correct materials to the same ID colours. 

It's a huge time saver, ensures consistency, and reduces error. If I decide a mesh needs tweaking and rebaking during the texture process then its non destructive.  I've used this approach for many years now because it works and means that the quantity of models I and a bunch of freelancers are expected to texture is feasable.

Except now it doesn't.
Now, when I select and load a new mesh via Project Configuration, Substance deletes most, and sometimes all, of my Layers!




3
Using 2019.3.1

In previous versions it was possible to drag the colour picker popup where ever you wanted and it would stay there. So you could move it close to where you were painting and could get colours without having to move your cursor across the screen. Not a biggie but overtime it becomes very tedious.

But worse is that I now find it can obscure areas of the screen that I want to look at or access and I'm not able to move it out of the way. That is not good.


4
So I'm now on 2019.3.0.

I've only just upgraded and in my previous version there was a tick box to "Override parameters common to all bakers"  .. so I could use different dilation widths, select specific UV maps, turn diffusion on and off and various other settings for each baker. 

This seems to of vanished which is kind of a shame as it was an essential part of my workflow and allowed me to get the baking passes all done quickly in one go. Have I just overlooked it or has it really been removed? 

Some of those features are suggested in the Bakers Render List but they can't be edited, except globally, so seem pointless.

Cheers.

5
I first asked for this about 4 years ago and it was declined.  Since our situation hasn't changed I'm asking for it again.

We're a game publisher and 70% of our developers use proprietary engines .. ie. non of the big names with their built in file compression. So for Substance Designer and Painter to be able to export directly to a properly supported dds exporter with settings that could be saved so exporting is automatic, would be a god send.

ATM we rely on unsupported free plugins for Photoshop ( very old Nvidia and newer Intel ) that are extremely labourious to use and could cease working with every new Photoshop update. This is really very, very bad. I could use more descriptive language but I'm sure you understand.

Thank you for the consideration.

6
Due to some very long projects I've been locked into early versions of Substance for several years - Painter 1.7.3 and Designer 5.62.

I'm now free to upgrade to 2019 versions and in doing so find there's only 22 days left of my Indie Subscription. Since the next projects are also likely to take several years I expect once the pipeline is tied down I'll be locked into this for the foreseeable future meaning there's little point in maintaining a subscription .. so with the new Adobe take over, what will happen in 22days? Will I automatically recieve a perpetual license?

Thanks,

Pat

7
SubstanceSubstance - Purchases & Licenses - Should I upgrade or not?
 on: November 26, 2018, 02:20:29 pm 
I'm probably not alone but I'm always confused by the upgrade policy and Black Friday isn't helping.

So I've just this minute got an email about the deal and how it ends today but I can't make out whether I need to upgrade today, whether my subscription will automatically renew or whether I should upgrade today becasue it just works out better financially. ... I've an Indie license that expires at the end of December and an old Perpetual licence of SD5 and SP1 that I'm not fussed about upgrading since I don't need two licenses.

Thanks.

8
So I own what was Substance Live Indie. I paid a subscription for 12 months or so and got SP1, SD5 and B2M3 as a package.

I'm now looking to upgrade that package as a whole but I'm being given 4 options  ..
SD on its own for $50 or
SP alone for $50 or
Substance using my SD licence for $19/month or
Substance using my SP licence at $19/month.

First two are clear enough. upgrade single programs.
But the latter two . . so are you no longer offering the equivalent of Live anymore? Where I can pay one subscription for all the software instead of having to deal with multiple subscriptions?  Or are these last two actually variations of the same thing?

Thanks for any help.

Pat

9
HI,

Currently using 5.6.2 and am finding the lack of mipmap support in dds export a real problem now. I've got hundreds of files  which all need mip mapping. Currently my best option seems to be the Intel plugin for Photoshop but it's a painfully slow process.

Can anyone confirm if SD6.x now supports this?

(Or maybe its been there all along and I'm missing something? There's the mipmap levels setting in the output panel but the exported dds contains non.)

Cheers,

Pat

10
Hi,

I'm using Atlas maker to bring together a set of tiles but I'm noticing an issue with some kind of offset ..

If you look at the picture, where its circled in pink you'll see some black lines .. they shouldn't be there and I can't get rid of them.

I'm using Substance 5.6.2.533, and a copy of Atlas Maker from June 2015.  (I've not upgraded as I'm mid project )

Has anyone seen this before? Is there a fix? Am I doing something wrong? I was going to report it as a bug but I've no idea if they still support previous versions.

Thanks.

11
Hi.

The title says it all really.

My old 580 has destroyed a fan so i'm looking to replace it. A 980 is way above budget and it appears the 970 should be avoided at all costs. But I'd really like 4Gb rather than 2 and am curious about the 960 with 4Gb. Is this a standard issue with all of Nvidias use of 4Gb or is this ONLY to do with 970?  Is there something specific in the specs I should be wary of?

http://www.ebuyer.com/721812-evga-geforce-gtx-960-superclocked-gaming-4gb-gddr5-dual-link-dvi-hdmi-04g-p4-1962-kr

Cheers,

Pat


12
Hi all.

Just returned to substance after being on a project that didn't require it (imagine!). Since last using it I've updated from Windows 7 to 10 and from SD 5.2.5 to SD 5.3.4.

For some reason I have no thumbnails in the graph view (Computing Node Thumbnails does nothing) or the library (Rebuild thumbnails via Preferences does nothing). See the attachment.

Is this a known issue with Windows 10 or this version of SD?
Has anyone else had a similar issue and fixed it?
Is it a Permissions or Security issue? All the relevant folders are  now set to Read/Writable (they were Read-only when I first checked).

Cheers,

Pat

Edit: note that Substance Painter does not have this problem.
        clicking on the red link in the library popup window takes me to the correct file in the correct location. I thought
        red text suggested an error?

13
Just hoping someone could confirm this is a problem before I try to report it.

I'm using Multi-Material Blend to blend together 4 materials. Using Wes' Atlas graph I've moved the materials to the four corners.
Colour, Spec, Opacity and Gloss are working fine, as you can see in the image .. materials 01, 02, 03 and 04 are in the correct positions.
But the normals aren't. Somehow its duplicating the normal map from material 01 in the place of those of materials 2,3 and 4. 

I've checked the original 4 materials and the normals are present and are being fed into the MMBlend.  This is SD 5.1.1 and 5.2

Pages: [1]