Author Topic: Baked textures get messed up when open saved file  (Read 3036 times)

Good day,

i have a big problem that occurs relatively often.

When i reload a scene Painter messes up almost all of my baked maps, so i have do rebake them. That's not only annoying but really time consuming, too and i find that should not be possible.

So maybe one can tell me what could be the problem?

Im running Painter 1.7.2, Nvidias driver is up to date (GTX670 4GB), didn't change anything on the included files since saving.

Log says this:

[Scene 3D] 3D scene successfully loaded
[Scene 3D] 3D scene successfully loaded
[Scene 3D] 3D scene successfully loaded
[Scene 3D] 3D scene successfully loaded
[Scene 3D] 3D scene successfully loaded
[Scene 3D] 3D scene successfully loaded
[GenericMaterial] VS compile log:
[GenericMaterial] ------------------
[GenericMaterial] File index:
[GenericMaterial] 0: shader-skeleton.vert.glsl
[GenericMaterial] 1: shader-common.vert.glsl
[GenericMaterial]
[GenericMaterial] shader-common.vert.glsl:22 | 1(22) : warning C7555: 'varying' is depre
[GenericMaterial] Program link log:
[GenericMaterial] ------------------
[GenericMaterial] Vertex info
[GenericMaterial] -----------
[GenericMaterial] 1(22) : warning C
[GenericMaterial] Creation of the shader pbr-metal-rough-with-alpha-blending successful

Greets

What do your actual bakes look like and how should they look, can you post a comparison shot?

Also, does it happen when you open the project or when you import an updated mesh?

It only happens when i open the project, i think the problem occurse in the Normal Map, World Normal and AO. Don't know if other maps show this behavior.
But i don't get it, i mean i#m baking the maps, they look alright! I save and quit, open Painter again and... it messes up the maps...

I did not change anything to the used 3D objects.

Attached i posted some comparison shots.

The weird ones are after opening and the good ones after rebaking them (They look obviously like they should, with no artifacts ect.).

What seems strange to me, is that the wooden frame does not show anything like the other two materials. Baked no model information at that one if that helps.

Greets and thank for your help.



Last Edit: April 04, 2016, 09:56:46 pm

Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Hey i attached the required files for you!

The scene itself is to big (700MB packed)
Last Edit: April 05, 2016, 02:33:14 pm

Without the project to reproduce the issue I'm not sure I will be able to find the problem.
Can you try to upload the file on dropbox or google drive ?
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Yep okay, i'll give it a try

So here is a link to my Onedrive-upload. Hope it'll work for you.

https://onedrive.live.com/redir?resid=6B50FBBCB7DF3F96!2596&authkey=!AP3hvmQ0fqF_HO8&ithint=file%2c7z

Hope we'll detect the fail


The file is corrupted, I can't extract it.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.


Got any news? The problem unfortunately still exists.

Sorry for the delay, I download three times your file but I still get a corrupted file. I even tried to extract it with multiple software to be sure.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.