Author Topic: [Solved]Cant paint on eyes (SubstancePainter 2)  (Read 3460 times)

Hey, I cant paint on a eye-mesh that I have connected to my dragon.
I sculpted the dragon in Mudbox, Imported it to MayaLT to add the eye-mesh and apply a
UV set. I combined the eye-mesh to the dragon, but it dosent show up in the UV set, nor in MayaLT or SubstancePainter. Here is some shots:




What can cause this?
Last Edit: April 10, 2016, 02:34:22 pm
System: G550JK -12GB ram, NVIDIA GeForce 850 2GB

The UVs are looking really weird. Have you UVd the high poly mesh from Mudbox? On top of that they seem very distorted in certain areas, you probably have applied some kind of auto mapping. I'd say the model you imported into Painter isn't at all ready to be painted on. You need to retopologize your model from Mudbox, create new UVs for that new low res model, and import that into Painter.

You also need to assign materials with unique names to your object (like e.g. a phong material named 'Eyes' for the eyes). Those names will be displayed in the TextureSet List in Painter. The TextureSet 'phong1' might be the eyes, who knows. Try to select it and check if you can paint on the eyes.

Last Edit: April 04, 2016, 10:44:45 am

Ah, maybe the UVset from Mudbox got carried over to MayaLT. Yes, I always to autoUVing in Maya as I find it that that is the only thing that works. I tried other UV options too, but things got messed up in earlier models. Will try to delete the UVset from Mudbox and import it again.
System: G550JK -12GB ram, NVIDIA GeForce 850 2GB

I always to autoUVing in Maya as I find it that that is the only thing that works.

I will not deter you from importing an auto-mapped highres-model into Painter of course, and it depends on what you are planning to do with your textured model, but if you want to texture it in Substance Painter in any remotely professional way (and do anything else with it but render a pretty picture for your personal gallery) I advise you to revise your workflow.

Study UV mapping techniques to begin with.
Last Edit: April 04, 2016, 12:15:20 pm

Thanks for your advices, I will see what I can do :)
System: G550JK -12GB ram, NVIDIA GeForce 850 2GB

I still cant figure out why I cant paint on the eye mesh even if it is combined to the creature mesh in Maya. Ive also tried a uncombined version. I tried to UV map the eyes to, but that didnt work. I got "better" UVs this time. Can you have a look at the file to see what I do wrong? If the textures shows up wierd in Maya, set the sRGB to ACE RRT v0.7.  Its a MayaLT file.

Dropbox file:
https://www.dropbox.com/s/ni6mseb266yxtvu/SmaugMayaEyeUV.fbx?dl=0



System: G550JK -12GB ram, NVIDIA GeForce 850 2GB



I fixed it :) I did as you said, applyed a new material to the whole thing and now it works!

Thanks again :)
System: G550JK -12GB ram, NVIDIA GeForce 850 2GB