Author Topic: Substance Painter Outputting Noisy Normal Maps?  (Read 5625 times)

Hi everyone

I've been having an issue with exporting normal maps from Substance Painter. I've searched around but couldn't find anyone else with the same issue, so I'm wondering if I've just done something stupid? Basically, when I export my normal map texture it becomes really, really noisy. Everything looks great in Substance Painter, but the output texture is nasty.


Here's a screenshot of what is going on:

http://i.imgur.com/erbxxIl.jpg

Can anyone help me out? I'd be very grateful for any pointers. I'm using the latest version (2.0.3). This is the first time I've experienced this issue, I've exported other assets with no problems.

Many thanks!

-John
--
John Barnard | Freelance Environment Artist, Pixel Pilgrim
john@pixelpilgrim.com | www.pixelpilgrim.com

Hey Pixel Pilgrim,

does the texture look good when using it in the target engine, for instance?
The objects pattern is not perfect smooth and maybe the normals just look too rough but are correct, actually.


Best Regards
Environment Artist - Twitter

Hi Fabian

Thanks for the quick reply :)

Nope, the normal map looks really wrong in both my 3d package and Unreal Engine.  It's almost as if the normal intensity is multiplied.

I've identified that the issue is coming from a single masked layer in my Substance Painter file that has a height value of 0.05. It's a very subtle bump in Substance, but when exported it becomes extreme.

Very strange indeed. It is as though instead of "0.05", I'm getting upwards of "100". Even pushing the value to 100 in Substance Painter doesn't make it look as extreme as the exported texture.

:S
--
John Barnard | Freelance Environment Artist, Pixel Pilgrim
john@pixelpilgrim.com | www.pixelpilgrim.com

On further investigation... any layer that has "height" enabled with a value higher than 0 results in really heavy bump in the normal map. Almost like there is a scale discrepancy somewhere... :/ Am I just using "height" incorrectly?
--
John Barnard | Freelance Environment Artist, Pixel Pilgrim
john@pixelpilgrim.com | www.pixelpilgrim.com

Make sure the height force in your shader settings is always set to 1, if not you'll see results that are not the actual exported maps.
Height maps can create very strong normal detail and their intensity should be set in the layer opacity, not with the Height Force setting.

A noisy height map used to create small grain detail or cloth fibers for example should have a very tight greyscale range centered around median grey (128), something like [120-136].

If the noise or map you use uses the full 0 to 255 range, you will indeed have to reduce the opacity of the height layer a lot.

Hi Jeremie,

Just wanted to say a big thank you for solving my issue!

I had accidentally set my "height force" to 0.1, hence the difference in the exported maps.

I really appreciate the help :) Thank you!
--
John Barnard | Freelance Environment Artist, Pixel Pilgrim
john@pixelpilgrim.com | www.pixelpilgrim.com