Author Topic: Problem with imported meshes  (Read 4497 times)

I'm having some kind of issue with triangulated surfaces imported from MODO into Painter. Attached is a subtle example of the problem. You can see the artifacts in the highlights on the top surface of the mesh. I've tried myriad different files and this seems to be fairly consistent. Can anyone tell me what is going wrong here, if there are settings or actions I need to take in either MODO or SP?

Why triangulated? I'm recreating a problem I'm experiencing with imported CAD files. Can't show the original files due to confidentiality. The mesh in these images was created natively in MODO, so I don't think it's a problem related to the CAD data.

I'm exporting .fbx files from MODO. The UV map was created using "Atlas", no tweaks. No other maps were created.

I also notice on 2nd glance that the part does not show the centerline crease. Could this be some kind of smoothing problem?

looks like a smoothing issue to me.  what version of modo you're using?

902. It looks like a smoothing issue to me too, but I don't know where it's coming from. The only map I'm exporting is the UV map. No normals, nothing.

.fbx is preserving the material smoothing properties in MODO. Turning that off helps in some cases, but not in others. The mystery continues.

check out James O'Hare toolkit for editing normals, that is, if you are not using the indie version - try softening all of the inner edges and harden the border and export again.
the normal editing tool in modo is awful, I think this kit is a must!
http://www.farfarer.com/resources.htm#
Last Edit: December 23, 2015, 11:28:17 am

That kit helps a ton. Thank you!

That kit helps a ton. Thank you!

HI,

Did you get everything worked out? Painter doesn't triangulate the mesh. There is an option to triangulate the mesh in the FBX options. The smoothing groups will work on FBX. With Modo, you need to create a Vertex Normal > Set Vertex Normals. Then you can select the faces and use the Edge>Split Normals.

Cheers,
Wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja

Hey Wes, thanks for following up on this. I got bogged down in the struggle and stepped away from the problem for a while, now back at it. Running the set/split normal loop you're suggesting results in eliminating all the polygon smoothing from the mesh, so every face looks faceted.

If you have the toolkit, harden the border edges and soften the inner ones.
Export as FBX with these settings (change in Preferences)


Let us know if that helped :]

I realized the error in my last post just after I posted it...;) I think what's happening here is that SP's viewport shows the smoothing problem more clearly than does MODO, but the problem is originating in MODO. I'm going to take this problem to the MODO folks and see what I can sort out on that end. Will post an update here if I make progress.

Thanks to zurhoch and Wes for the patient feedback and support.