Author Topic: Substance Designer has stopped working error  (Read 22921 times)

Working for me yesterday, tried to boot up today and crashes just after the splash screen. My guess is it is a licensing issue, either the server is down or the change in year has caused a problem.
I am on Live too.

My guess is it is change in year has caused a problem.

moved the date of yesterday, ceased crashing on startup

Yup it stopped on my machine as well. I'm glad you folks are seeing this too because i was wondering how it could have possibly been broken on my machine because it was working completely fine last time i used it and i never changed anything.  :P


I have the same problem on OS X.
It refuses to launch with:

Process:               designer [82947]
Path:                  /Applications/SubstanceDesigner/Substance Designer_old.app/Contents/MacOS/designer
Identifier:            org.allegorithmic.substance_designer
Version:               5.3.0 (5.3.0)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           designer [82947]
User ID:               503

Date/Time:             2016-01-02 18:09:19.051 +1100
OS Version:            Mac OS X 10.10.4 (14E46)
Report Version:        11
Anonymous UUID:       


Time Awake Since Boot: 1200000 seconds

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000000


Yeah setting the system date to December 31st 2015 did the trick for me as well. Thanks for the hack!

Yeah setting the system date to December 31st 2015 did the trick for me as well. Thanks for the hack!
setting system date to january 1st 2016 too working

So strange. Happened to me just now.

I tried re-installing and restarting my computer, and running as administrator, among other things. Nothing worked. Substance Designer would not start.

I changed the date to yesterday on my computer just now, and it started just fine. :P
3D art is magic.

It's happening to me as well : we are investigating

I just had the same problem, setting the calendar back a day worked... but well its not an ideal fix you know.
Last Edit: January 02, 2016, 10:05:08 am

Same error for me too !
I tried to reinstall, changed location,... nothing !
But substance designer 4 still works ! :)
Last Edit: January 02, 2016, 10:20:56 am

Same here :(

We are investigating the problem.

In the mean time you can install SD 5.2.5 which is not affected by this issue.
Go to your Allegorithmic account / Downloads / Substance Designer 5 / See all build versions
Product Manager - Allegorithmic

Same issue here, was working just fine few days ago.

( temporary solution)

window time rollback we can solve it. +_+

ex) On December 1, 2015




http://imgur.com/a/kkJNq
Last Edit: January 02, 2016, 12:16:42 pm

Not to be left out it is hitting me too Mac so nothing todo with the OS. I am guessing a Date related code issue.
Good luck tracking it down.
Mark.
Freelance 3d Artist Modo Substance
Mark TomlinsonMarkBTomlinson - Substance Tools Group