Author Topic: Texture export size limit to 2048?  (Read 12199 times)

Hi everyone,

I have Substance Designer 3 and i want to export my sbsar files in 4096x4096 or in a larger format when I need it. Is there a way for this?

I tested a lot of things but it doesn't work.. :
Change Output size in absolute > 4096 : That give me a 2048 file.
Change Output size parent to 1 and render a 2048 file in Substance Player : it crash.

I need some help, 2048 is too small for some of my work, do you have an idea for fix this?

Thanks !

PS : For information, i work in a Mac (10.7.4, i5, 4go DDR3)

Only crashes I experienced are when I try to:
- render texture 8k and higher in Substance Player - it alone eats 1.5GB of RAM during generation
- render texture in Substance Player when Designer is open

My tips:
- make sure you use the GSLS renderer (Mac) or DirectX (Windows) in the player
- try not to use Designer and Player at the same time - conserve your resources. Also check the amount of memory being eaten by generating specific texture sizes.
- simplify your blend nodes - do not use alpha blending if your textures doesn't use it
- use operations on greyscale images - works faster, eats less resources
- if all else fails, use Substance Batch tools - with them I can cook 8k textures with no problem (didn't try bigger), just write yourself some custom script in ie. python

Hope you will solve your problem.

I use i5, 8GB RAM, Win 7 x64.

Hi t.leszczynski and thanks you for your help !

I try again with your recommandations : i closed Designer and other applications and i made tests with differents Substance files, complex and not.

Player is really more stable, but it always crashs when my RAM is down to 1Go.

So, it's a good opportunity for me to test Substance batch tools, but i have another problem... (I actually don't think this is a problem, I just have to make a mistake somewhere)

.sbscooker, it works perfectly, it's really usefull
.sbsrender give me always the same error : "Segmentation fault: 11", even with differents files.

I make my test directly in Terminal for having a simple request :
{sbsrender_path} render {sbsar file path} --output-path {output path} --output-format jpg

Maybe the problem is caused by --set-value, i don't understand the syntax in help ( Usage [input identifier]@[filepath of image].).

Any idea?

Thank you again for the help !

Ok, i've just download the last substance batch tools version and it's works, thanks !

The only "problem" is now the --set-value parameter in render batch tool, i don't understand it. I've test a lot of value but it always render a 256x256 file.

If your graph is set to RelativeToParent, I would say you need to use --set-value $outputsize@11, $outputsize is the default name of the resolution parameter in Substance and 11 being 2^11= 2048.

Fot this to work, you need to have checked the Output Size box when publishing the substance.

Hello Jeremie,

Thanks for your help, i understand now, it works with this synthax in mac Terminal : "--set-value '$outputsize'@11,11"

With this, i have a perfect 2048x2048 texture but when i try a biggest size, like 12 for 4096 or more, the batch tool return a error : "Abort trap: 6".

I found many request on internet which returns this error "Abort trap: 6", but it's not specific to batching tools and it's beyond me.

little by little I'll get there.. anyway, thank you for your help!

edit : with some files i have the error, with some not but the jpg output is horrible. I test with a lot a sbsar and some have only two or three non-complex node. Weird...

edit 2 : I update my Mac to last OS : 10.8.2, same problems
Last Edit: March 10, 2013, 06:59:22 pm

Hi vincs,
Are you running the Batch Tools directly from the Terminal, or are you calling it from an external script?
"Hinhin!" :-D

One note for the horrid jpg output - you can use png, bmp, tga, tiff etc. I usually use png or tga.

Hi and thanks again for your help !

Thanks for the tips t.leszczynski. I try again, with a lot of .sbsar files in differents formats (bmp, png, jpg, tga) but I still have the same problem when I try to create files greater than 2048x2048px : "Abort trap :6"

Raouf Bejaoui,  yes i running the batch tools directly from the terminal, to avoid any error due to a script. Is it a mistake?

Are you all on Windows to make your batch?

edit : i tried also with a absolute size 4096x4096 in the .sbs file, publish in .sbsar and baked it : same problem.
Last Edit: March 11, 2013, 01:26:01 pm

I try to update Substance Designer to 3.2.3 (I had version 3.2.2) and I also do a lot of minor updated my OS, but same problems.

(and sorry for english, i'm a french guy)
Last Edit: March 11, 2013, 01:56:00 pm

Yes, I'm using Win7 x64.
After checking the log after publishing substance in Designer "\Users\[you_username]\AppData\Local\Allegorithmic\Substance\log.txt" it looks like the substances are cooked in it with fixed max output size of 12 (4096px).
I don't know if that's a feature or a bug. The value for "Cooking size limit" in Preferences/Advanced is valid only for substance size inside Designer.

Try using the sbscooker with higher max output size, it's the "--size-limit" argument and check your own substance designer log, maybe it will help. Or maybe sbsrender ignores that setting, I don't know - I was using batchtools for cooking & rendering from start with size set to 13.

I'm running out of ideas :P
Maybe you should make/upload any texture you're having a problem with, for other person with batchtools to check.
I can try rendering it on Win if you decide on that option.
Last Edit: March 11, 2013, 04:49:52 pm

Hi t.leszczynski,

Sorry, I have a lot of work this week, but I tried to watch all this as soon as possible, thank you again for your help!
I also managed to find a windows license, I think I'll install it this weekend, to see if the problem is related to the OS.

I come here when I have something new, thank you again!