Author Topic: Substance Designer 3D View port - Shadow problem Please help  (Read 4123 times)

Good day.

I have been following Rogelio Olguins tuts on Gnomon and it looks like he has much darker defined shadows in his 3d Viewport when he is moving the light around and previewing the normal and height maps he is creating.

For some reason on my 3d View port, the per pixel shadows are muted or very hard to see. How do I get darker shadows?

Please help!

Here is another example.

Even when I grab the light and move it around no shadows change over my preview. It's like real time shadows got turned off!

Please help. It's making it very difficult to preview my results and I want to get the most out of this 30 day trial version before I make up my mind to purchase.

Thank you.

Try to set a higher value in the normal filter (16 or 32 for instance).
Product Manager - Allegorithmic

Thanks for getting back to me.

By Filter, Did you mean to increase the normal Intensity in the Normal Map node?

I tried increasing it to 32 and it does make my surface bumpier however when I grab the lights and move them around the real time shadows are not behaving like they should. It must be a render setting for lights or shadows.

Any ideas?>
I searched every button on the interface. lol


The lights in the opengl view don't cast shadows.
Product Manager - Allegorithmic

Rogelio was using OpenGL in the video. You can see the detailed shadows in the pics.
http://www.thegnomonworkshop.com/store/product/1149/#.VlUUZv-FN9A

Thanks in advance!

The image on the top in certainly rendered in marmoset toolbag.
If the 3d opengl view in designer had shadows, I think we would be aware of it ;)

But, the iray renderer has shadows!
Product Manager - Allegorithmic

How would it be rendered in Marmoset when you can clearly see the UI is from Designer. :)

To get the shadows you have to turn off the IBL (HDR panorama). 3D View > Materials > Default > Channels > Latitude/Longitude panorama
Also you might want to increase the point light's intensity (lights > edit), don't forget that you can type in higher number than 10. Lastly you should use normal maps as well, you can always increase its intensity as well.

Took me a few hours to figure this out, it is really unfortunate that nobody tells this, not even the guy in the tutorial. (Although the rest of the tutorial is really great!)

Fisher