Author Topic: Substance Designer won't launch  (Read 3284 times)

Hey everyone, I downloaded the trial version of the latest sd and after I install I try to open the program it won't launch. No matter how many times I tried to unistall and delete everything, it simply won't work. It's as if I never clicked to open it. It pops up for a bit on windows task manager and then it's gone. Any ideas as to what's wrong and how I can fix it?

Hi,

We would need to know more about your computer :
  • CPU brand and model
  • graphics card brand and model
  • OS and its version
  • desktop or laptop

Hey, here are my specs :
Intel Core i7 (5th Gen) 5500U / 2.4 GHz
NVIDIA GeForce 840M / Intel HD Graphics 5500 - 4 GB
Windows 7(x64)
16G Ram
Laptop
It's drivers are updated.

Can you make sure (using the NVIDIA control panel) that the NVIDIA graphics card is actually used with Designer, and not the integrated graphics ?

Thanks for the suggestion, but it doesn't work. I tried to do it manually too, but it didn't work either.   :'(

Do you have an antivirus installed ?
We've seen a similar problem where the antivirus prevents some files to be copied during the install process.

Try to disable the antivirus and reinstall the last SD 5.3.1 version.
Product Manager - Allegorithmic

Well, from ignoring me, now it says SD has stopped working as soon as i click to open it. Now it's getting frustrating because I also downloaded the Marmoset Toolbag trial and it does the same thing exactly. Maybe there is something wrong with my computer. I can't say..

Hi, I have same problem

Theses are my specs :

Intel(R) Core(TM) i7-4810MQ CPU @ 2.80GHz, 2801 MHz, 4 cores, 8 processors

NVIDIA GeForce 860M - 2 GB / Intel HD Graphics 4600 - 1 GB (integrated)
Windows 10(x64)
24G Ram
Laptop : NoteBook W35xSS_370SS (XMG)

Both display drivers are updates
Bios update too
Disable Anti virus ..

The driver NVIDA force Substance designer to use driver's.

My problem is :
When I start substance designer, splash screen of designer open and close severals seconds later is closed,
and nothing is work.
No message error.

This is last version of designer I install.
Substance_Designer-11.1.2-4593-msvc14-x64-standard

these are last lines from C:\Users\username\AppData\Local\Allegorithmic\Substance Designer\log.txt :
....
[INFO][IRay] neuray header  API interface version = 43
[INFO][IRay] neuray header  API version           = 4.1
[INFO][IRay] neuray library API interface version = 43
[INFO][IRay] neuray library build version string  = Iray RTX 2020.1, build 334300.2228, 11 Aug 2020, nt-x86-64
[INFO][IRay SDK]    0.0   API    db   info : Loaded "C:\Program Files\Allegorithmic\Substance Designer\plugins\iray\libneuray.dll"
[INFO][IRay SDK]    0.0   API    misc info : Iray RTX 2020.1, build 334300.2228, 11 Aug 2020, nt-x86-64
[INFO][IRay] Plugin directory set to 'C:/Program Files/Allegorithmic/Substance Designer/plugins/iray'
[INFO][IRay] Loading plugin 'nv_freeimage'...
[INFO][IRay]    Plugin successfully loaded.
[INFO][IRay] Loading plugin 'axf_importer'...
[INFO][IRay]    Plugin successfully loaded.
[INFO][IRay] Loading plugin 'mi_exporter'...
[INFO][IRay]    Plugin successfully loaded.
[INFO][IRay] Loading plugin 'nvcuvid_video_decoder'...
[INFO][IRay]    Plugin successfully loaded.
[INFO][IRay] Loading plugin 'libiray'...
[INFO][IRay]    Plugin successfully loaded.
[INFO][IRay] Loading plugin 'iray_bridge_client'...
[INFO][IRay]    Plugin successfully loaded.
[INFO][IRay] Starting IRay...
[WARNING][IRay SDK]    1.1   IRAY   rend warn : CUDA device 0 (NVIDIA GeForce GTX 860M): device is deprecated for technical reasons. Iray may retire CUDA compute capability 5.0 in the next major release.
...




Is anyone have an idea ?

Thanks :)
Last Edit: April 30, 2021, 07:05:19 am
Ef !

Hi again ..
I have tested severals olds versions of substance designer on my laptop,
And the last is worked id this one :

Substance_Designer-2019.3.3-3313-msvc14-x64-standard

Versions 2020 don't worked.

.. May be it is  the solution, or it is some developpement in the future that compatible with my computer ?

Ef !

I see in SD 2019 it is possible to change preferences of CPU/GPU of IRAY
Is it possible to edit theses preferences for 2021 version, at startup without UI ? 

(screenshot joined)
Last Edit: April 30, 2021, 07:04:05 am
Ef !