Author Topic: [SOLVED] SD 5.3 Surface Pro 3D bug  (Read 2118 times)

The latest update for Substance Designer has seemed to have broken the 3D view on my Surface Pro 2, and leaves a strange graphical error. Substance Painter also happens to suffer from the same problem, but SP had done this for a while now.



I don't think there are any new video card drivers for the Pro 2, but I can use 5.2.5 for the time being.

(Also, love SD and SP very much, stay awesome Allegorithmic!)
Last Edit: October 10, 2015, 11:34:04 am

What is the GPU model on the surface pro 2?
Is it Intel HD 4400?
Product Manager - Allegorithmic

yeah, it has the 4400

Product Manager - Allegorithmic

I get an error when trying to install the new drivers, saying that "the driver isn't validated for this computer". Most Surface Pro 2 drivers have to go through Microsoft and get downloaded through Windows Update, so I'm guessing that's why it's not "validated". 5.2.5 still works under the current drivers, however.

I get an error when trying to install the new drivers, saying that "the driver isn't validated for this computer". Most Surface Pro 2 drivers have to go through Microsoft and get downloaded through Windows Update, so I'm guessing that's why it's not "validated". 5.2.5 still works under the current drivers, however.

Hi,

You need to manually update the GPU driver. I have done this on my Surface Pro 3.
http://lifeisabug.com/installing-latest-intel-hd-graphics-driver-microsoft-surface-pro-pro-2-pro-3/

Cheers,

wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja

Using that guide I was able to update my drivers and SD is working perfectly again. Thanks Wes and Nicolas!