Author Topic: Import from Blender always has smooth shading  (Read 5451 times)

I'm pretty noob with all of this stuff, but when I'm finally able to open the mesh into substance painter from a blender fbx, all my shading is set to smooth instead of what I have it to from blender. I've tried several different export options that would be related to it but never any change. I could model a building in blender and it would look like a marshmallow in substance painter. I'd love some help figuring this out.

What works for me is to export using the FBX format.  I use the default 7.4 binary option and set Smoothing to "Face".

The smooth and flat faces in my blender model appear correctly in Substance Painter and Designer.

Try these settings, works for me both designer and painter. I'm using Blender 2.75a.


I'm not sure how yours smoothing is but just in case here how I has it:

In Blender I usually first smooth everything, then enable auto smooth in properties panel and after that select corners/edges that I want to have sharp smoothing in Shading/UVs tab using edges.

Selecting edges in Shading tab for making sharp corners might not be necessary in this case, think can just adjust value of auto smooth to get wanted look for structure parts (if it is a building).

More info about smoothing itself in here:
https://www.blender.org/manual/modeling/meshes/smoothing.html

Last Edit: August 05, 2015, 01:26:28 pm

Obj works fine for me -