Author Topic: Some library thumbnail previews for PBR materials are completely black.  (Read 3335 times)

Hi, I have the latest Substance Designer as well as Substance Database 2.1. Some of the thumbnail previews in the Library for the PBR Database substances are just black. Others from the same folder are just fine.

I've tried rebuilding the thumbnails several times, but that doesn't change anything. It doesn't show these materials as computing the thumbnails, they're just black.

All bitmap-based substances display their previews with no problems.

Any ideas?

Can You try with the 5.2.1 version we just released?
Product Manager - Allegorithmic

Thanks for the quick reply. Yes, I had updated to 5.2.1 and tried rebuilding thumbnails before I posted. I just did it again to no avail after seeing your post.

can you post a screenshot and the log ? (help/export log)
Product Manager - Allegorithmic

Here's a screenshot:



This happens at all icon sizes.

Here's the log file:
Download.

Edit: this is not a bug..
Product Manager - Allegorithmic

The PBR materials contains output for both Diffuse/Specular and Basecolor/Metallic workflows.

And the library always renders the first output it finds and the first input is generally the diffuse output. And for metallic materials, the diffuse output is generally black!
Product Manager - Allegorithmic

I see...

Will there be some sort of solution to this? It's very time consuming to have to bring in each item to the graph and hook it up just to see what the substance looks like.

Thanks.

Showing the basecolor won't help more as it'll basically be a uniform color.

We'd have to make a full material render (like I substance painter) but it's a lot more complicated to do ;)
Product Manager - Allegorithmic

I understand. Hopefully it will be considered for a future release. Thanks for the prompt support!

A quick fix for this is to go into the graph properties and move the "diffuse" output below "basecolor" in the "Output Images" tab. Won't work for SBSAR files, obviously ;/