Author Topic: [CRASH] Substance Painter + Windows 10 + nVidia 350.12  (Read 46319 times)

355.82 out today.  Crossing fingers.

Still got the same error. This is really dissapointing. Can't use Substance Painter since Windows 10 release. And going back to 347 is not really an option since other applications prefere an up-to-date driver..... :(

Noooooooo. That is extremely disappointing.

Hey Nicolas or Wes, do you have any information if the fix was already in the new driver? If it was already implemented, then something else crashes painter now. I think it takes longer now to crash painter, but it still crashs.

Last Edit: September 01, 2015, 05:31:55 pm

Is there still no new news of Windows 10 support? Allegorithmic, this is unacceptable if I really have to go back to Windows 7 to use SubstancePainter. I dont want to downgrade the nVidia driver either.
System: G550JK -12GB ram, NVIDIA GeForce 850 2GB

Ok Guys,

I think I found a hack, which will allow you to use the newest Nvidia Drivers with Windows 10. It is not a real solution, but a hack to get it to work (at least my tests were really promising without a crash).
It seems, that painter (and OpenGL) occupy the graphic card for a such a long time, that windows doesn’t get a response from the drivers/ GPU and thinks it have to restart the drivers. That crashes painter.
There is a possibility to let Windows wait longer for a response from the GPU and don’t restart the drivers.
I played with painter for some time without crashing (before the hack it crashed all the time).

You have to edit the registry for this. (DO this only if you feel comfortable editing the registry). Close all programs before editing the registry. You will need administrator privileges. You can do a backup of the registry, by opening the registry editor (regedit.exe) and goto file -> export and save a copy.

1.   Open the registry with Start and type in the search field “regedit”. Or open a command prompt and type “regedit”.
2.   Browse to “HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers”
3.   With “Edit” --> “New” create a QWORD (for 64Bit) or a DWORD (for 32Bit).
4.   Name it “TdrDelay” and give it the value (Double click on TdrDelay) of “8”
5.   Close regedit (no need to save) and restart your computer

I hope this will work for you. It seems, that it helped me (didn’t had much time to test, but in cases were painter normally crashed, it worked). Remember, this is just a hack and it is not what causing the problem. Hopefully Nvidia or Allegorithmic will find a solution soon.

Happy painting!

Cheers
Ingo

P.S. Please let me know if it worked for you!

Ok Guys,

I think I found a hack, which will allow you to use the newest Nvidia Drivers with Windows 10. It is not a real solution, but a hack to get it to work (at least my tests were really promising without a crash).
It seems, that painter (and OpenGL) occupy the graphic card for a such a long time, that windows doesn’t get a response from the drivers/ GPU and thinks it have to restart the drivers. That crashes painter.
There is a possibility to let Windows wait longer for a response from the GPU and don’t restart the drivers.
I played with painter for some time without crashing (before the hack it crashed all the time).

You have to edit the registry for this. (DO this only if you feel comfortable editing the registry). Close all programs before editing the registry. You will need administrator privileges. You can do a backup of the registry, by opening the registry editor (regedit.exe) and goto file -> export and save a copy.

1.   Open the registry with Start and type in the search field “regedit”. Or open a command prompt and type “regedit”.
2.   Browse to “HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers”
3.   With “Edit” --> “New” create a QWORD (for 64Bit) or a DWORD (for 32Bit).
4.   Name it “TdrDelay” and give it the value (Double click on TdrDelay) of “8”
5.   Close regedit (no need to save) and restart your computer

I hope this will work for you. It seems, that it helped me (didn’t had much time to test, but in cases were painter normally crashed, it worked). Remember, this is just a hack and it is not what causing the problem. Hopefully Nvidia or Allegorithmic will find a solution soon.

Happy painting!

Cheers
Ingo

P.S. Please let me know if it worked for you!


Thanks Ingo for taking the time to research and share this information.  Unfortunately, it didn't work for me.  Still crashing here.  I've posted a screenshot of my registry setting.  Let me know if I did anything wrong.   Thanks!

Dan

Interesting about TdrDelay. I did some research on it and found this thread on the nvidia forums:

https://forums.geforce.com/default/topic/503962/tdr-fix-here-for-nvidia-driver-crashing-randomly-in-firefox/

It seems to say that not only do you change GraphicsDrivers\TdrDelay but also GraphicsDrivers\DCI\Timeout to the same value. They also use a much higher value (0x60 in hex or 96 in decimal).

It also seems pretty clear reading the thread that changing these values are a band-aid on a bigger issue. It's not a fix, but a workaround and will probably still crash, just not as often.


Thanks Ingo for taking the time to research and share this information.  Unfortunately, it didn't work for me.  Still crashing here.  I've posted a screenshot of my registry setting.  Let me know if I did anything wrong.   Thanks!

Dan

Hi Dan,

it seems right. It's the same as I did. Maybe I was just lucky, or didn't tested it enough.
Sorry, that it didn't worked on your side.

Cheers
Ingo :)

P.S. You could try a higher value. That means, that windows will wait longer for a response. I got a Geforce 960 and was trying with a simple model, If you try with a more complex model, and the operation will take longer to compute, maybe a higher value will work for you.

P.P.S. Tried it with a more complex model and it also crashed for me. So back to start :(
Last Edit: September 02, 2015, 09:34:37 am

Interesting about TdrDelay. I did some research on it and found this thread on the nvidia forums:

https://forums.geforce.com/default/topic/503962/tdr-fix-here-for-nvidia-driver-crashing-randomly-in-firefox/

It seems to say that not only do you change GraphicsDrivers\TdrDelay but also GraphicsDrivers\DCI\Timeout to the same value. They also use a much higher value (0x60 in hex or 96 in decimal).

It also seems pretty clear reading the thread that changing these values are a band-aid on a bigger issue. It's not a fix, but a workaround and will probably still crash, just not as often.

Didn't know about the Timeout. Yes, like I said, it is a quick hack and no solution for the timeout. Within my short test, I couldn't get painter to crash, were it normaly always crashed. I also found a link to a Microsoft site where this procedure is descriped:
https://support.microsoft.com/en-us/kb/2665946. I hope for a solution from Nvidia or allegorthmic. Hopefully soon :)

Hey guys, little update on this issue :
nVidia fixed the problem and we had the opportunity to try out a beta driver, so I can confirm it's now fixed internally. I'm waiting for a confirmation regarding the driver number that will include this fix. Meanwhile I suggest staying with the drivers 347.x.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Froyok aka Fabrice Piquet, Technical Artist and Product Designer at Allegorithmic.

Hey guys, little update on this issue :
nVidia fixed the problem and we had the opportunity to try out a beta driver, so I can confirm it's now fixed internally. I'm waiting for a confirmation regarding the driver number that will include this fix. Meanwhile I suggest staying with the drivers 347.x.

Good to hear! Thanks for letting us know!

Ill reinstall Windows 7 Ultimate :) Coulndt wait any longer.
System: G550JK -12GB ram, NVIDIA GeForce 850 2GB

The new GeForce driver with the OpenGL fix will be available today. :)
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Froyok aka Fabrice Piquet, Technical Artist and Product Designer at Allegorithmic.

The new GeForce driver with the OpenGL fix will be available today. :)

Great news!!!! Hopefully everything will work fine after that!! Yeeehaa :)