Author Topic: I can not open any substances in cinema 4d r16 mac osx 10.7  (Read 8062 times)

Hey..I'm new to substances at all. I've also watched the presentation/tut on cineversity and got the trial.
But in Cinema( using r16 on mac os x 10.7) I'm not able to load substances via the asset-manager.
I can choose/load a file(sample files and other free sbsar.'s) but in the asset-manager only the name and the substance-logo will be displayed. No channels(preview-icons) and in the attribute-manager on >asset>status>"Invalid Substance Asset file" is displayed.When I trie to create a material out of the asset-manager nothing happens.
.. I tried to reinstall, restarted the machine and gave accsess to internet(for possible authentification).
Still the same..so whats the matter/problem?
Thanks very much

Hi alex_stautmeister,

Is this using your own substance, or a substance provided with the trial/tutorial?

Hi josh,
these were the sample files provided with the plugin..but also a few more I found online( just about 2 or three) ...I thought more about a faulty installation or so..
Thank you

Hi Alex,

is the location of the Substances in any way special? Or are these located on your local hard drive?
As long as you follow the set-up instructions in the documentation, I can hardly believe in an installation error. After all the plugin seems to successfully start...

Bye,
Andreas
Cheers,
Andreas

SDK Support Engineer
MAXON Computer GmbH

Hi Andreas,
you're right i thought so too but once i had a similar problem with vray-installation.. one folder was placed right but not the other..In this case it's just one folder and like you said the plugin is loading..the assetmanager is there..The console also says sd-plugin successfully initialised.. I didn't mention about the sbsar.s because they were provided by the producer and were used in the tut too.
I just checked compatibility with other plugins by disabling them but nothing changed either.
Anyway the plugin starts and I think the key is the 'status' in the 'object-manager':Invalid Substance Asset file.
And no it's just the default location(cinema4d/plugin/substance) on local harddrive.
thanks for your effort,
Alexander
Last Edit: June 23, 2015, 03:39:13 pm

Hey alex, typically the error you mention should only occur if the file couldn't be opened or the data within is read incorrectly.

Can you answer a few more things for me:

1) Can you load substances if you have a c4d scene loaded? What if there is none?
2) When asked to copy the substance to your project folder, what happens if you say yes or not?
3) Can you load these sbsar files in Substance Designer?

Hey josh,
it's the same if I copy the files to project folder or not. There is no problem about loading them into substance-player.
About the first question I feel a bit retarded..I'm not sure how it's meant. Do you mean inside C4D with objects etc or without ->new document. Or if a cinema scene is open in the background while loading sbsar.s into substance designer or player for example. Sorry it's not my mother tongue.
Alexander

No problem Alexander!

I just wanted to know if substances loaded if you had a .c4d file loaded, versus no file. you would load Cinema 4D and then immediately go to load sbsar, not load a c4d file first.

Another thing that may or may not be an issue. I've only tested C4D on 10.9 and 10.10 OSX... is there any way you could try the plugin on a new version of OSX?


Hey..
sorry for the late response..it's the same. In both cases the same result>>Invalid Substance..
I think I will try to upgrade the os but I guess this will take some time.
Thank you,
Alexander

Hi alex,

We are going to see on our end as well if there are issues with 10.7. If you can update to Mavericks or Yosemite that would be ideal though.

Hey.. and sorry once again for late response.
It took some time but finally I did the upgrade to Yosemite and now it's working.
Thank you very much for your effort.

Hi alex,

I'm glad it is working for you. We will update our  documentation to avoid further confusion.

Josh

I get the same error and I'm on windows 10 with C4d R17.

The error happens with or without any C4D scene loaded.

The substance asset loads ok into Substance Painter.

Hi vaporlaser,

Are you trying to load a substance archive (sbsar) or substance painter project (spp)? We only support sbsar files with the C4D plugin.

Hi vaporlaser,

sorry, you are having problems. Perhaps you can provide us with the Substance you are trying to load, so we can test it here?
Cheers,
Andreas

SDK Support Engineer
MAXON Computer GmbH