Author Topic: [SOLVED] I can't register Painter/Designer  (Read 4258 times)

I bought live subscription few days back. When I'm starting either of them I get Activation Wizard as normal. When I try to add a license key or try to register via website, activation wizard freezes and program won't respond anymore. I can see license for both at my account/downloads -> "my licenses". Tried running them as Admin. Tried add them as trusted programs for Firewall (comodo). Nothing seems to work.
HELP!

It seems that it does the same thing even if I select "Evaluate this product"...


Last Edit: July 25, 2015, 11:51:46 pm

Hi,

It seems your OS does not allow the software to write the license in the folder...
Can you give me your specs? Is this a Dell/Alienware PC?

Cheers,
Nicolas
Head of Product Management

Not a Dell/Alienware machine.

AMD FX-6100 3.3 GHz
8 Gb RAM
Geforce GTX 670 2GB
Windows 7 64-bit Home Premium (with SP1)

Do you need any additional, more specific info?
 
Last Edit: June 13, 2015, 08:11:07 pm

Hi,

Do you have administrator rights on your computer ?

Can you check if you have a license.key file already install in C:\ProgramData\Allegorithmic\Substance Painter ?

Can you tell me what your username is on your computer ?

Thx

Alex
Last Edit: June 15, 2015, 09:36:11 am
Senior Software Engineer
Substance Painter Team
@achassany

Yes, I am admin for this machine.
..\Allegorithmic\Substance Painter -folder is empty
..\Allegorithmic\Substance Designer -folder has a subfolder named "5" but that one is empty too.
My username is "Käyttäjä" (user in finnish. Really imaginative, I know. :D )

I just downloaded new version for Substance Painter and activation works!
Substance Designer still behaves same way though, Program stops working.

I guess you've made some changes for Painter - Thanks for that! :D
...now I'll just wait new version for Designer. ;)

-K
Last Edit: July 05, 2015, 11:23:42 am

Hey kari,

can you test it without umlauts, please?
Special Characters are somehow broken with Substance Designer, as far as I know.


Best Regards
Environment Artist - Twitter

Hi,

I can confirm - it was umlauts. I had "ä" in my username. Changing the name in account manager does not help. You have to create new user with correct naming. A kind of pain in the butt but atleast its working now. Thanks for all your replies!

-K