Author Topic: Black Normal map in version 5.1.1  (Read 4977 times)

Hi, I am getting black normal maps in version 5.1.0 and with the update 5.1.1. The same mesh is baking fine in version 5.0.3 with the same settings. Other maps all seem ok. The high and low meshes are fbx exported from c4D R16. Any ideas?

Is the "Match" option set to "Always" ?
Product Manager - Allegorithmic

More questions :
  • If you bake a world space normal with the same settings and mesh, is the result also black ?
  • Can you tell us your OS and hardware specs (CPU, GPU, drivers release if on Win) ?

Thank's for replies,

Yes, Match is set to "Always". I tried "by mesh name", same result.

World space normal with same settings is fine.

Im on a mac running Mavericks 10.9.5

Machine is 2 x3.33 Ghz 60core intel xeon (12 core)

GPU is ATI Radeon HD 5770 1024 MB

Regards Steve



I thought it might be the graphics card but I have just updated on my laptop from 5.0.3 to 5.1.1 and the same thing is happening...

MacBook pro 2.6 i7
NVIDA GeForce GT 750M 2048 MB

It's probably a bug we already found and fixed, but too late for the 5.1.1 release : OSX's OpenGL drivers do not support a function we started using in 5.1.0 to check the world to tangent space conversion results. This will be fixed in the next release, but at the moment we don't know when that will be.

OK, thank's Cyrille.

Will you still supporting OSX going forward and are the older versions of SD available to download so I can generate normal maps?


I also have this problem in 5.1.1 and I have tried the suggested solutions and am having no luck.
I'm on a mac using Yosemite 10.10.3
2.6 intel i7
GeForce GT 650M

Check to make sure under preferences that Tools->Preferences->Projects->Tangent Space Plugin: You have something set.  I ran into an issue where it was linked to an old dll that I deleted and it generated black maps.

@Dtinkler : Sorry, there is no workaround at the moment. Until the next release, the only solution to bake tangent space normal maps on OSX with Designer is to reinstall Designer 5.0.3.

Will you still supporting OSX going forward
Of course.

Quote
are the older versions of SD available to download so I can generate normal maps
Yes, they should be available on your Allegorithmic account. You would need to revert to 5.0.3.
Last Edit: June 09, 2015, 07:15:11 pm

Hi,

same issue to me (on a Mac), I've baked with SP and it worked really fine, but in SD I can get only black or white maps. Occlusion map, for example, bakes fine on both.

Also I have a wrong rappresentation in SD of the Normal green channel in the 3D view using MikkT, is appears to be "skipped" or flat. The error occurs even with normal maps baked in SP,  while the same mesh with the same normal map looks fine in Blender, SD and UE4. It goes ok when I switch to UnityTSpace. I was trying to bake normals in SD but it's not possible for now. Anyway I've already opened another thread about this, but I was wondering if those things could be correlated.

Hi,

same issue to me (on a Mac), I've baked with SP and it worked really fine, but in SD I can get only black or white maps. Occlusion map, for example, bakes fine on both.

Also I have a wrong rappresentation in SD of the Normal green channel in the 3D view using MikkT, is appears to be "skipped" or flat. The error occurs even with normal maps baked in SP,  while the same mesh with the same normal map looks fine in Blender, SD and UE4. It goes ok when I switch to UnityTSpace. I was trying to bake normals in SD but it's not possible for now. Anyway I've already opened another thread about this, but I was wondering if those things could be correlated.

Hi,

The black normal map is a bug in the OS X version. We will have this fixed ASAP. I posted the resolution for the green channel issue in your thread in case anyone else runs into a similar issue.

Cheers,

Wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja

Same problem. Had to downgrade to 5.0.3

Hi.

Same problem here. Baked tangent space normals in SP fine.
SD 5.1.1 on a Mac Pro (AMD)  just giving black or white maps. Baking other maps seems fine.

Cheers

Simon

I'm sorry for this delay. We have this issue logged and will get this resolved ASAP.

Cheers,

wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja